Bug 452436 - "RuntimeError: Error running reiserfstune" after detailed disk layout dialog
"RuntimeError: Error running reiserfstune" after detailed disk layout dialog
Status: CLOSED DUPLICATE of bug 446513
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-22 18:46 EDT by Petr Machata
Modified: 2015-05-04 21:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 14:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First fail log. (24.46 KB, text/plain)
2008-06-22 18:46 EDT, Petr Machata
no flags Details
Second fail log. (30.02 KB, text/plain)
2008-06-22 18:46 EDT, Petr Machata
no flags Details

  None (edit)
Description Petr Machata 2008-06-22 18:46:09 EDT
I was installing F 9 from live CD to oldish i386 athlon machine.

My situation is as follows. I have two disks, sda and sdb.  sdb is "new" disk, I
have had sda before that.  For that reason, sda contains several partitions that
used to serve purposes of /boot, swap, and /.  Nowadays I use sda as /boot, swap
and /home, while having / on the "new" disk, sdb.  /home partition is pretty
aged reiserfs, the rest are ext3 partitions (and swap).

What I did when presented with disk layout dialog was that I requested detailed
view (sorry, forgot how is it called exactly).  There I assigned sda1, sda2 and
sda3 respectively to /boot, swap and /home.   I allowed reformatting of sda1,
but not of sda3 (obviously).  It bothers me a bit that anaconda tried to run
reiserfstune even though I asked it not to mess with that partition, but there
could have been legitimate reasons for that.

I assigned sdb solely to / (which is to say that there was single partition sdb1
on that disk), and asked anaconda to reformat it.

Then I hit next, and anaconda thrown the exception.  I tried the whole process
three times total, each time reducing the amount of my tinkering.  In the end I
just didn't use detailed view at all, and just ticked out sda and let anaconda
do its magic.  This worked.

I will attach the two fail logs that anaconda spewed.
Comment 1 Petr Machata 2008-06-22 18:46:09 EDT
Created attachment 310003 [details]
First fail log.
Comment 2 Petr Machata 2008-06-22 18:46:45 EDT
Created attachment 310004 [details]
Second fail log.
Comment 3 Chris Lumens 2008-06-23 14:10:14 EDT

*** This bug has been marked as a duplicate of 446513 ***

Note You need to log in before you can comment on or make changes to this bug.