Bug 45244 - Installer exits with signal 7
Installer exits with signal 7
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-20 20:32 EDT by Nick Blackwell
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 09:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Blackwell 2001-06-20 20:32:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
I hit <enter> at the boot: prompt after booting from the CD, and after the 
installer finds my hardware, it shows a blue screen for a few seconds then 
that goes away, and it says the installer exited abnormally with signal 
7.  I also tried lowres mode, but that gave the same result.

How reproducible:
Always

Steps to Reproduce:
1.Start install program in graphical mode
2.
3.
	

Actual Results:  Installer exited and said I could now safely restart my 
computer.

Expected Results:  Installer should have asked desired boot mode (i.e. CD-
ROM).

Additional info:

I'm running the following:
Abit KT7-RAID mobo (with Promise ATA-100 controller),
Creative 3D Blaster Annihilator 2 Ultra,
SB Live X-Gamer,
3Com 10/100 card,
HP CDWriter 9300,
Toshiba DVD-ROM,
ATAPI Zip drive
Comment 1 Brent Fox 2001-06-21 15:19:11 EDT
When the install crashes, can you press <Ctrl><Alt><F4> and see if there are any
error messages there?
Comment 2 Nick Blackwell 2001-06-21 20:31:23 EDT
The signal 7 has now changed to a signal 11.  I checked where you said to look, 
and the only thing that looked like an error was a line that read:

Unable to identify CD-ROM format

Also, there were some devices sharing IRQs, but that shouldn't be a problem, 
right?
Comment 3 Brent Fox 2001-06-26 13:32:30 EDT
Can you try booting with 'linux ide=nodma' and see if that helps?
Comment 4 Nick Blackwell 2001-06-26 13:43:32 EDT
I had already tried it, but I just got a different error at about the same 
place.  I'll try it again though and record the error.
Comment 5 Brent Fox 2001-06-26 14:47:07 EDT
Ok.
Comment 6 Nick Blackwell 2001-06-27 19:54:43 EDT
I tried running linux ide=nodma, and again anaconda exited abnormally, but 
without a Signal 11.  Under <ctrl><alt>F4, nothing looked different than 
before.  Under <ctrl><alt>F3, the last line was "looking for USB mouse" but 
that could be the same as before.  Also, under F4, the last few lines were:

raid0 personality registered as nr2
raid1 personality registered as nr3
raid5: measuring checksumming speed
...(here it output some test results)
raid5:using function: p5_mmx (3284.800 MB/sec)
raid5 personality registered as nr4

I don't know if that last part means anything, but it was the last few lines 
under F4.
Comment 7 Brent Fox 2001-07-10 12:32:51 EDT
It's hard to say what the problem is.  It's not getting far enough into the
installer for me to do any meaningful debugging.  Can you look on VC1 and see if
you see a line that says "Running anaconda"?  If you don't see that, then
anaconda hasn't even started, which means there either a kernel problem or
there's something wrong with the hardware.
Comment 8 Nick Blackwell 2001-07-10 13:19:07 EDT
It definitely did say "Starting anaconda"
Comment 9 Matt Wilson 2001-07-13 02:30:37 EDT
Were there any more messages at all on <Alt+F1> ?
Comment 10 Nick Blackwell 2001-07-13 18:40:07 EDT
Actually, the error message changed again.  The entire output after "running 
anaconda" under <ctrl><alt><F1> is as follows.

Running anaconda -- please wait
exec: Exec format error
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
     /proc/bus/usb
     /mnt/runtime
     /mnt/source unmount failed ()
     /dev/pts
     /proc
you may safely reboot your system
Comment 11 Chad Scott 2001-07-16 17:15:25 EDT
I see this same error on a dual-processor 1GHz Pentium III... Running on an 
ABIT VP6, latest BIOS.  It happens on both fail-safe and optimized settings.  
I've tried everything I can think of to solve this, including disabling the USB 
bus, turning off my Adaptec card, etc.

I see exactly the same errors as the previous reporting person.

I have an Adaptec SCSI controller with a single CD-RW attached.  I can give 
more thorough specs if you want.
Comment 12 Matt Wilson 2001-07-18 18:52:15 EDT
try booting with "ide=nodma"
Comment 13 Nick Blackwell 2001-07-19 00:02:19 EDT
Just like before, that didn't work, but now I got a Signal 11 again.  By the 
way, I also tried Expert mode, and I got through a few screens, but anaconda 
exited at the exact same point.
Comment 14 Matt Wilson 2001-07-24 00:30:52 EDT
this is a data corruption error and will have to be handled kernel level.
Comment 15 Nick Blackwell 2001-07-24 00:56:26 EDT
So, what do I do about that?
Comment 16 Arjan van de Ven 2001-07-30 09:42:17 EDT
This is almost certainly a hardware issue. I assume none of these systems
are overclocked ?
Comment 17 Nick Blackwell 2001-07-30 23:13:11 EDT
Nothing's overclocked at all.  I've used the video card control panel to boost 
the speed on that, but that should only affect the Windows driver, right?
Comment 18 Nick Blackwell 2001-09-20 21:16:06 EDT
Can you update me on this?  It's been almost 2 months, and I recently tried it 
again, getting the same errors.  I'd like to know if there's been any 
progress.  Thanks.
Comment 19 Arjan van de Ven 2001-09-21 04:14:56 EDT
Somehow your cdrom drive has problems reading the cd. Would it be possible to
do either a network install or an install from harddisk (where you copy the cd's
(as iso files) to harddisk first) ?
Comment 20 Alan Cox 2003-06-06 09:55:47 EDT
Closing: No reply in > 18 months.

Note You need to log in before you can comment on or make changes to this bug.