Bug 452442 - Replace phpeclipse with PDT
Replace phpeclipse with PDT
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-phpeclipse (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-22 20:17 EDT by William Lovaton
Modified: 2008-11-11 09:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 09:23:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lovaton 2008-06-22 20:17:15 EDT
Any plans on replacing phpeclipse plugin with PDT??

http://www.eclipse.org/pdt/
http://www.zend.com/en/community/pdt

phpeclipse doesn't seem to be maintained anymore.

PDT instead looks very active.
Comment 1 Mat Booth 2008-06-23 10:46:20 EDT
Well, the last commit to PHPEclipse was only a couple of weeks ago[1]. I began
packaging the latest subversion snapshot of version 1.2.0 when I took over this
package just recently. (The code we have in Fedora at the moment is over two
years old.) I will have some time at the weekend to finish it off and get it
into Rawhide, I reckon.

I agree that development is rather slow upstream, but it hasn't stopped
completely, and as the maintainer I'll do my best to fix bugs reported here and
push patches upstream. Which isn't to say I'm against packaging PDT, I just
don't have any plans to do it myself at the moment.

[1] http://dev.phpeclipse.com/browser/trunk?order=date
Comment 2 William Lovaton 2008-06-23 12:02:30 EDT
Ok, it's nice to hear that it is not completely dead and that you are taking
care of the package.

Mat, do you know if it is possible to configure PDT with Fedora Eclipse?? since
the Eclipse version included in Fedora is compiled in native code I guess there
should be some quirks making PDT play nice with Fedora Eclipse.

I guess the same applies to any other Eclipse plugin outside the Fedora effort.
 Is there any documentation about using external plugins with Fedora Eclipse??
Comment 3 Andrew Overholt 2008-06-23 14:13:33 EDT
Don't worry about the gcj bits - they're only used / needed if you're using gcj.
 Using plugins that aren't packaged as RPMs should "Just Work".  Install using
the update manager, etc.  If there are issues, please file them.
Comment 4 Andrew Overholt 2008-06-23 14:18:34 EDT
At some point in the past someone told me that PDT required a proprietary
debugging tool.  Is that still the case?  Does debugging even work with
phpeclipse (as packaged in Fedora)?
Comment 5 Mat Booth 2008-11-11 09:23:28 EST
PHPEclipse has been updated since this bug was filed and I don't plan on doing anything else with this bug. There's been no response from the submitter to Andrew's question either so I'm gonna close it.

Note You need to log in before you can comment on or make changes to this bug.