Bug 45246 - XFree86-4.1.0-0.5.9: unresolved symols in /usr/X11R6/lib/modules/fonts/libbitmap.a
Summary: XFree86-4.1.0-0.5.9: unresolved symols in /usr/X11R6/lib/modules/fonts/libbit...
Status: CLOSED DUPLICATE of bug 44954
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-21 01:33 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-21 03:12:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my XF86Config-4 file (1.81 KB, text/plain)
2001-06-21 01:33 UTC, Jonathan Kamens
no flags Details
Log from failed X server run (3.71 KB, text/plain)
2001-06-21 01:34 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2001-06-21 01:33:08 UTC
I finally decided to bite the bullet and try once again to upgrade from the
XFree86 3.3.6 Mach64 server to the XFree86 4 server with the ATI driver. 
The last time I tried this, quite a while ago, the results were so
disastrous that I was scared away from using the XFree86 4 server for quite
a while.

This time, Xconfigurator seemed to generate an XF86Config-4 file for me
with no problem.  However, when I tried to use it, to start the server, I
got a whole bunch of errors of the form "Symbol .LC2 from module
/usr/X11R6/lib/modules/fonts/libbitmap.a is unresolved!"  I am at a loss to
explain these.  I will attach my XF86Config-4 file and the log from the
failed server run.

Needless to say, I have reversed to the XFree86 3.3.6 server for the time
being :-).

Any advice?

Comment 1 Jonathan Kamens 2001-06-21 01:33:34 UTC
Created attachment 21426 [details]
my XF86Config-4 file

Comment 2 Jonathan Kamens 2001-06-21 01:34:08 UTC
Created attachment 21427 [details]
Log from failed X server run

Comment 3 Stephen Rasku 2001-06-21 03:12:52 UTC
See bug 44954 as well.

Comment 4 Mike A. Harris 2001-07-03 01:09:37 UTC
Yes this is a known problem which is due to changes in gcc that do not work
well with the X module loader.  A new package will be available before long,
please read the dupe bugs for details.

*** This bug has been marked as a duplicate of 44954 ***


Note You need to log in before you can comment on or make changes to this bug.