Bug 452491 - ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 448739 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-23 08:36 EDT by Stephen
Modified: 2010-04-05 15:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 09:36:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen 2008-06-23 08:36:35 EDT
Description of problem:

Started noticing this message in /var/log/messages:

    ath5k phy0: noise floor calibration timeout (2442MHz)

over and over and over...

When this happens there is what feels like 99% packet loss.

Turning the network off and back on in nm-applet, or just clicking on the
associated wifi link again reassociates no problem and the network works great
for a few minutes.  Until it trips over again...

The network is unencrypted G, about 50% signal strength. There is one other
visible network in the area, on a different channel, about 20% signal strength.

Up until now the driver has been working great so I'm not sure what's setting it
off. If it is some new interference that's triggering it, then perhaps ath5k is
being a little too sensitive as my nokia 770 can handle it fine and as I
mentioned, it seems to recover if I manually poke it.


Version-Release number of selected component (if applicable):

kernel-2.6.25.6-55.fc9.i686


How reproducible:

It's annoyingly reproducible right now, but it's been working fine for the last
few weeks. I'm guessing I won't be able to reliably test this.
Comment 1 John W. Linville 2008-06-23 15:12:34 EDT
*** Bug 448739 has been marked as a duplicate of this bug. ***
Comment 2 John W. Linville 2008-11-20 14:09:02 EST
Wow, long time...are you still experiencing this with 2.6.27-based kernels?
Comment 3 Stephen 2008-11-27 02:38:01 EST
Yup:

Nov 24 18:14:22 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Nov 24 18:18:52 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Nov 24 18:40:33 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Nov 24 18:40:54 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Nov 24 18:42:25 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Nov 24 18:42:56 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Nov 24 18:43:07 yo kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Comment 4 Stephen 2008-11-27 02:40:14 EST
Woops, sorry. That's actually with kernel-2.6.26.6-79.fc9.i686.

I'll upgrade to F10 and let you know.
Comment 5 Stephen 2008-12-06 01:29:22 EST
Still getting the log spammed with 'noise floor calibration timeout' messages, plus, an additional one:

Dec  5 19:24:51 localhost kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Dec  5 19:25:02 localhost kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Dec  5 19:37:53 localhost kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Dec  5 19:43:21 localhost kernel: ath5k phy0: noise floor calibration timeout (2447MHz)
Dec  5 19:43:21 localhost kernel: ath5k phy0: ath5k_chan_set: unable to reset channel (2447 Mhz)
Dec  5 19:44:34 localhost kernel: ath5k phy0: noise floor calibration timeout (2462MHz)
Dec  5 19:44:55 localhost kernel: ath5k phy0: noise floor calibration timeout (2462MHz)


I don't believe the channel of the base station actually changed...
Comment 6 Kelly-Rand 2009-01-10 11:51:49 EST
I am also getting the same log messages for the ath5k driver.
This is an F10 i686

lspci
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller (rev 41)
07:00.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)

# uname -r
2.6.27.9-159.fc10.i686
Comment 8 John W. Linville 2009-01-13 16:15:10 EST
F10 build w/ patch to address this issue:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=78354

F9 build w/ the same patch:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=78385

When those builds complete, please give them a try and post the results here.  Are you able to recreate this issue with those kernels?
Comment 9 John W. Linville 2009-01-13 16:17:50 EST
Wrong URL for the F10 build in comment 8.  Correct URL is below:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=78384

Please try that one instead of if you are using F10.
Comment 10 John W. Linville 2009-01-13 16:24:28 EST
Crud, sounds like F9 kernels are being reverted back to 2.6.27.  F9 users will have to wait a while before a kernel is available w/ the patch above.
Comment 11 John W. Linville 2009-01-22 14:24:24 EST
No one brave enough to try the kernel from Koji?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=78384
Comment 12 Kelly-Rand 2009-01-23 21:34:16 EST
OK, I've downloaded the kernel, devel and headers. It will be at least a week before I can comment.
Comment 13 Quentin Armitage 2009-01-24 13:23:55 EST
All the 2.6.28 F10 kernels I have tried, including 2.6.28-1, 2.6.28-4 and 2.28.1-19 hang while udev is starting.

I have installed 2.6.27.12-170, which as the patch applied, and I am no longer seeing the noise floor calibration timeout, whereas I was with the 2.6.27.9-159 kernel.
Comment 14 John W. Linville 2009-01-26 09:36:52 EST
Yes, the 2.6.28 w/ F10 issue is ongoing...but as in comment 13 the patch in question is available on the later 2.6.27-based kernels for F10 as well.

Closing on the basis of comment 13...thanks!
Comment 15 keith 2009-05-04 11:07:06 EDT
Unfortunately, the opposite is true for me. Since the latest kernel (2.6.27.21-170) I have been seeing the failures start again. 
Only a power off will clear the state.
Comment 16 Tim Niemueller 2009-07-13 17:41:57 EDT
I still see this problem on a F-11 machine, it's a Thinkpad T43 with an Atheros AR5212 in an 802.11G network. The problem is pretty annoying, although it does not loose the connection it has ping times of several seconds and name lookups fail very often. It's working just fine from another laptop with iwl3945. Are others also still experiencing this problem? How could you fix it otherwise?
Comment 17 Kelly-Rand 2009-07-13 20:34:01 EDT
Tim,
There is a new bug opened for F11:
498662

This is interesting that it has arisen again. I fixed it on my laptop with one of the koji 2.6.28 kernels with F10. I am still using that kernel since January.

Jim
Comment 18 Enygma 2010-01-19 09:15:40 EST
$ dmesg
...
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)
ath5k phy0: noise floor calibration timeout (2462MHz)

$ uname -r
2.6.30.10-105.fc11.i586

It struck me again today and it's driving me crazy. It continuously breaks my connections every minute or so. I can't really do anything, hardly posting this bug report.

I will be very thankful when someone will manage to get rid of this old and annoying bug.
Comment 19 Germano Massullo 2010-02-24 13:01:59 EST
I have this problem with my Thinkpad T41:
when I use the wifi, lots of times the computer freezes for 0,5 sec and the wifi led blinks.
If I go in dmesg I have:

ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2447MHz)
ath5k phy0: noise floor calibration timeout (2452MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2447MHz)
ath5k phy0: noise floor calibration timeout (2452MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2452MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2447MHz)
ath5k phy0: noise floor calibration timeout (2452MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2447MHz)
ath5k phy0: noise floor calibration timeout (2452MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2447MHz)
ath5k phy0: noise floor calibration timeout (2452MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)
ath5k phy0: noise floor calibration timeout (2442MHz)
ath5k phy0: noise floor calibration timeout (2447MHz)
ath5k phy0: noise floor calibration timeout (2457MHz)

Note You need to log in before you can comment on or make changes to this bug.