Bug 452544 - HDD requirements very deprecated
HDD requirements very deprecated
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
http://docs.fedoraproject.org/release...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-23 13:09 EDT by Michel Samia
Modified: 2008-08-26 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 19:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Samia 2008-06-23 13:09:33 EDT
Description of problem:
Very deprecated information about disk space requirements

Version-Release number of selected component (if applicable):
Chapter 6 (Architecture Specific Notes)

How reproducible:
Try to install a full installation on a pc with 30GB HDD.

Steps to Reproduce:
1. perform a standard F9 installation on PC with 30GB HDD
2. $ su
3. # yum --skip-broken install '*'
4. wait few hours (depends on your system, I highly recommend use a local
intranet mirror...)
  
Actual results:
Installation of package '(something)' requires 4 GB HDD space...

Expected results:
Correct information about HDD requirements in chapter 6 (30 GB was not enough..)

Additional info:
Comment 1 Michel Samia 2008-06-23 13:12:12 EDT
the actual value in the documentation is about 9 GB
Comment 2 Karsten Wade 2008-06-23 18:02:08 EDT
What you are saying is, there is not enough space on 30 GiB disk to install
_every_single_Fedora_package in the Fedora 9 repo?  I want to confirm that is
what you mean (status of bug set to NEEDINFO.)

http://mirrors.kernel.org/fedora/releases/9/Everything/i386/os/Packages/

I'm actually not surprised about this.  The above repo has 9897 packages in it,
at this moment.  That content was originally written and updated to reflect a
specific package set, in this case, the DVD spin done by Fedora's release
engineering team.  It is in fact possible that 9 GiB is incorrect for that DVD
installation, but not by the amount you are suggesting.

What we won't ever do is try to accurately count for the size of every single
package that could be installed at any given time.  With dozens of new packages
added each week, that is chasing a storm.  It is the responsibility of a
specific spin to post information about their full install as well, but since no
one is making a spin bigger than a single DVD (currently), 9 GiB probably works
for them.

It does make sense to note in the documentation more carefully that this number
is related specifically to the largest spin of Fedora put out by the Fedora
Project, which is the Fedora 9 DVD.
Comment 3 Michel Samia 2008-06-24 08:32:15 EDT
Yes, you're right. I meant the web repository. I know that installing so much
packages is not wise for normal usage, I only wanted to test something (I wanted
to run sectool  - fedorahosted.org/sectool - to see how many errors it will find...)

I forgot that the web repository is much bigger that the DVD - that it is not
the same set of packages (and that the info in the documentation is about DVDs). 

I agree with you that it is a bad idea to rewrite the documentation with each
added package.. I was only surprised how big Fedora is. I see the solution (as
well as you) in mentioning that 9 GB is concerning to the DVD, not to the full
web repository. 
Comment 4 Jason Taylor 2008-08-26 17:27:14 EDT
The release note content has been changed to reflect the discussion above.

Note You need to log in before you can comment on or make changes to this bug.