Bug 452755 - system locks up when starting
system locks up when starting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 16:29 EDT by Aram Agajanian
Modified: 2018-04-11 08:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.26.3-29.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 15:05:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file that uses radeonhd driver (1.11 KB, text/plain)
2008-06-24 16:29 EDT, Aram Agajanian
no flags Details
log file when using radeon driver and computer locks up (68.46 KB, text/plain)
2008-06-25 16:27 EDT, Aram Agajanian
no flags Details
Xorg log file from PC with Radeon HD 2400 XT hardware using radeonhd driver. This was the first run and there was no crash. (199.87 KB, text/plain)
2008-06-26 11:48 EDT, Aram Agajanian
no flags Details
Xorg log file from PC with Radeon HD 2400 XT hardware using radeon driver. This was the first run and there was no crash. (68.64 KB, text/plain)
2008-06-26 11:52 EDT, Aram Agajanian
no flags Details

  None (edit)
Description Aram Agajanian 2008-06-24 16:29:11 EDT
Description of problem:
My PC has an ATI Radeon HD 2400 XT video card.  When I boot F9, the 
rhgb screen runs OK until then end.  Then, the video gets corrupted
and the whole system locks up.  It seems like the problem occurs 
when gdm is started, but I'm not sure of that.

I had been using the radeonhd driver with good results with F8, but
the same xorg.conf file doesn't work with F9.

Version-Release number of selected component (if applicable):
1.2.1-3.2.20080622git.fc9

How reproducible:
I believe that the problem has occured every time that I have booted
with the radeonhd driver under F9.  There have, however, been a few 
times that I have restarted gdm and the problem hasn't occured.

Steps to Reproduce:
1.modify xorg.conf to use radeonhd driver
2.reboot
3.at the end of rhgb, the system hangs
  
Actual results:
The screen gets corrupted and the system hangs.  The only way that I
know of to revive it is to hold down the power button until it powers
down.  Then, I press the power button again to start the computer.

Expected results:
The GDM greeter screen should start without screen corruption or hangs.

Additional info:
Comment 1 Aram Agajanian 2008-06-24 16:29:11 EDT
Created attachment 310181 [details]
xorg.conf file that uses radeonhd driver
Comment 2 Matěj Cepl 2008-06-25 05:47:24 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as
individual uncompressed file attachment using the bugzilla file attachment link
below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Hans Ulrich Niedermann 2008-06-25 06:05:50 EDT
Thanks for the report.

The last stable radeonhd version which appears to work for just about anyone
with a supported card is xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9 which
is in the F9 updates.

All later xorg-x11-drv-radeonhd snapshots have had regressions, and I fear you
have run into one again.

If you want a quick workaround, I'd suggest you either
  * revert to xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9
    (if you need fast user switching)
  * switch to xorg-x11-drv-ati's "radeon" driver
    (if you do not need fast user switching)

Of course, we appreciate your help in testing xorg-x11-drv-radeonhd. I will take
this up with upstream when we have the /var/log/Xorg.*.log file here, preferably
when Xorg has been started with '-logverbose 7'.
Comment 4 Aram Agajanian 2008-06-25 16:27:43 EDT
Created attachment 310293 [details]
log file when using radeon driver and computer locks up
Comment 5 Aram Agajanian 2008-06-25 16:40:28 EDT
I did some more testing of the computer locking up when using the radeonhd
driver.  First, however, I updated the radeonhd driver to the 20080429 release.

What I found is that when using either the radeonhd or radeon drivers, there is
a problem.  The first time that I start the X server, it runs OK.  However, the
second time that I start the X server, the screen becomes corrupted and the
computer locks up.  This problem does not occur with the vesa driver.

The first time that I start the X server, first I see a grey background and a
mouse pointer that looks like an X.  Then, the mouse pointer changes to an arrow
and the GNOME desktop appears.

The second time that I start the X server,  the GNOME desktop background appears
right away.  The grey background doesn't come up first.  When using the radeon
or radeonhd drivers, the screen becomes corrupted and computer locks up.  When
using the vesa driver, the GNOME desktop comes up and works properly.

When using the radeon driver and starting the X server for the second time, I
log file was generated.  I have already uploaded that log file as an attachment.

When using the radeonhd driver and starting the X server for the second time, no
log file was generated.

To be specific, my testing procedure was:

1) boot to runlevel 3
3) run the command "startx -- -logverbose 7"" as non-root
3) delete the log file
4) run the command "startx -- -logverbose 7" again as non-root
5) turn off computer with the power button
6) reboot to runlevel 3
7) look for new log file
Comment 6 Aram Agajanian 2008-06-25 17:05:40 EDT
I just tested running Xorg with no configuration file.  I found that Xorg
behaved similarly to when there was a minimal configuration file and the driver
was specified as radeonhd or radeon.

One thing that I noticed is that, again, no log file remained after the computer
locked up and was power cycled.  It seems as though the presence (or absence) of
the log file on reboot may not be related to the driver (radeon or radeonhd).
Comment 7 Hans Ulrich Niedermann 2008-06-26 06:03:05 EDT
OK, so we have a problem with both the radeonhd and the radeon driver.

Would you mind attaching the Xorg.N.log files from both test runs with radeonhd
as well?

BTW, if you 'startx -- :2 -logverbose 7' it should end up in Xorg.2.log, which
is not overwritten by Xorg.0.log later.
Comment 8 Aram Agajanian 2008-06-26 11:48:59 EDT
Created attachment 310347 [details]
Xorg log file from PC with Radeon HD 2400 XT hardware using radeonhd driver.  This was the first run and there was no crash.

As previously mentioned, the first run is OK but the second run hangs the
computer.  I am able to get a log file from the first (which is this
attachment) but not the second run.
Comment 9 Aram Agajanian 2008-06-26 11:52:36 EDT
Created attachment 310348 [details]
Xorg log file from PC with Radeon HD 2400 XT hardware using radeon driver.  This was the first run and there was no crash.

As previously mentioned, the first run is OK but the second run hangs the
computer.  I am able to get a log file from the first run (which is this
attachment) but not the second run.

Since I am unable to generate a log file from a hung computer, I believe that
the log file that I attached yesterday was from a first run (not a second run).
Comment 10 Hans Ulrich Niedermann 2008-07-15 07:04:10 EDT
I have consulted with radeonhd's Luc Verhaegen. He says

   "[I]t's consistent between radeonhd and radeon, first X
    server run, libpciaccess provides correct data, second
    X server run, libpciaccess provides us with wrong data"

and

   "[I]t's a general issue with at least the xserver
    [or drm/kernel]".

Given that the default driver for the card in Fedora is radeon from
xorg-x11-drv-ati, I am assigning this bug over to -ati and hope the more
knowledgeable people over there can figure out where the actual issue is.
Comment 11 Hans Ulrich Niedermann 2008-07-16 11:30:57 EDT
I am guessing here, but this might fix it:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=56358

Could you try that, please?
Comment 12 Aram Agajanian 2008-07-16 12:07:50 EDT
I installed xorg-x11-drv-radeonhd-1.2.1-3.4.20080716git.fc9.x86_64.rpm and tried
to use the radeonhd driver.  The lock up problem persisted for the second time
that X is run.
Comment 13 Aram Agajanian 2008-09-17 15:05:03 EDT
The latest kernel (the first 2.6.26 release) fixes this problem.

Note You need to log in before you can comment on or make changes to this bug.