This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 452776 - system-config-network does not support configurations using bonding
system-config-network does not support configurations using bonding
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
Branislav Blaškovič
: OtherQA
Depends On:
Blocks: 1049888 557926
  Show dependency treegraph
 
Reported: 2008-06-24 21:31 EDT by Charles Duffy
Modified: 2016-01-05 07:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the "system-config-network-cmd --import" command did not correctly handle bonding interfaces. Consequently, when using this command to import a setting generated with the "system-config-network-cmd --export" command, the configuration of bonding interfaces was lost. This bug has been fixed and "system-config-network-cmd --import" now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:17:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Duffy 2008-06-24 21:31:04 EDT
Description of problem:

system-config-network does not model the MASTER or BONDING_OPTS field from
ifcfg-*. This means that export/import roundtrips are lossy for configurations
using bonded interfaces, and result in a broken network configuration.


Version-Release number of selected component (if applicable):

system-config-network-1.3.99-2.el5.src.rpm


How reproducible:

every time


Steps to Reproduce:
1. configure a system with a bonded interface
2. system-config-network-cmd --export -do > somefile
3. mkdir -p testpath/etc/sysconfig/networking/profiles/default # this works
around another bug
3. system-config-network-cmd --import --clear -do --root=testpath --file=somefile
  
Actual results:

"somefile" contains no entries mapping the ethernet devices to the bond devices
to which they belong (MASTER) or entries providing options to be used in
configuring bonding (BONDING_OPTS). Generated ifcfg-* files thus also do not
contain this data; indeed, ifcfg-bond0 is not even created, although somefile
describes bond0.

Expected results:

"somefile" should reflect the master bonding device for each network device
marked as a slave. ifcfg-* files created on import should include appropriate
MASTER=<bond_device> lines reflecting this.
Comment 7 Harald Hoyer 2009-05-11 10:28:17 EDT
Please test the erratum candidate: 
http://people.redhat.com/harald/downloads/system-config-network/system-config-network-1.3.99.17.1.el5/
Comment 8 Chris Ward 2009-07-03 14:04:01 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 9 Charles Duffy 2009-07-28 19:53:18 EDT
This issue does not appear to be resolved:

Given the test procedure filed with the initial ticket, the MASTER= parameter is correctly preserved and generated in the produced ifcfg-eth*, but while DeviceList.BOND.bond* is produced in the exported file (and correctly preserves BondingOpts), no ifcfg-bond* is created under testpath/etc/sysconfig/network-scripts/ on --import.
Comment 10 Charles Duffy 2009-07-28 19:57:46 EDT
(In reply to comment #9)
> This issue does not appear to be resolved:
> 
> Given the test procedure filed with the initial ticket, the MASTER= parameter
> is correctly preserved and generated in the produced ifcfg-eth*, but while
> DeviceList.BOND.bond* is produced in the exported file (and correctly preserves
> BondingOpts), no ifcfg-bond* is created under
> testpath/etc/sysconfig/network-scripts/ on --import.  

To clarify -- this was against the system-config-network-tui-1.3.99.18-1.el5 package from the 5.4 beta.
Comment 11 Chris Ward 2009-07-29 08:58:11 EDT
Dell,

It's getting very late into the release cycle. Chances are lowered daily with regard to our ability to commit new code into 5.4. Speak with your Partner Manager for more details about the schedule particulars.

At this phase, we are excepting only release blocker items. Therefore, if you feel this item must be fixed in RHEL 5.4 as originally planned, it is vital that you provide a business justification for blocker status as soon as possible. 
Otherwise, this request will need to be deferred to RHEL 5.5.

Thank you for your understanding and expedited response, and we are sorry for any inconvenience this might cause.
Comment 14 Suzanne Yeghiayan 2009-07-31 17:45:25 EDT
Move from RHEL 5.4 to 5.5 since no response from Dell by today's deadline.
Comment 15 RHEL Product and Program Management 2009-11-06 13:52:37 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 19 Branislav Blaškovič 2014-05-16 06:15:35 EDT
According to comment #9, this was not fixed.

Harald, was this fixed in some newer version? Source rpm does not contain patches so I cannot verify it.
Comment 20 Harald Hoyer 2014-05-22 06:12:21 EDT
(In reply to Branislav Blaškovič from comment #19)
> According to comment #9, this was not fixed.
> 
> Harald, was this fixed in some newer version? Source rpm does not contain
> patches so I cannot verify it.

the reproducer of the initial bug report should be fixed
Comment 21 Harald Hoyer 2014-05-22 06:20:14 EDT
(In reply to Branislav Blaškovič from comment #19)
> According to comment #9, this was not fixed.
> 
> Harald, was this fixed in some newer version? Source rpm does not contain
> patches so I cannot verify it.

https://git.fedorahosted.org/cgit/system-config-network.git/log/?h=Branch-RHEL5

this is the fix for this bug

https://git.fedorahosted.org/cgit/system-config-network.git/commit/?h=Branch-RHEL5&id=0a570694e4bb5ee1fdada0d3c7d79fa7d1c11660
Comment 22 Branislav Blaškovič 2014-06-03 09:04:50 EDT
Marking as SanityOnly as this is OtherQA.
Comment 23 Branislav Blaškovič 2014-06-04 08:45:21 EDT
# cat testpath/etc/sysconfig/network-scripts/ifcfg-eth0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth0
HWADDR=52:54:00:a1:d2:1d
MASTER=bond0
BOOTPROTO=none
ONBOOT=yes
USERCTL=no
IPV6INIT=no
SLAVE=yes
PEERDNS=yes

# grep -e Master -e Slave somefile 
DeviceList.Ethernet.eth0.Master=bond0
DeviceList.Ethernet.eth0.Slave=true
DeviceList.Ethernet.eth1.Master=bond0
DeviceList.Ethernet.eth1.Slave=true

# rpm -q system-config-network system-config-network-tui
system-config-network-1.3.99.23-1.el5
system-config-network-tui-1.3.99.23-1.el5

Looks ok. Verified.
Comment 24 Branislav Blaškovič 2014-06-04 09:05:02 EDT
According to comment #23, this bug is no longer SanityOnly as I've done proper testing. 
Removing SanityOnly tag.
Comment 26 errata-xmlrpc 2014-09-15 20:17:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1195.html

Note You need to log in before you can comment on or make changes to this bug.