Bug 452823 - When there's no right EUS channel fail more gracefully
When there's no right EUS channel fail more gracefully
Status: CLOSED DUPLICATE of bug 378341
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.7
All Linux
low Severity low
: beta
: ---
Assigned To: Pradeep Kilambi
Fanny Augustin
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-25 07:02 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-25 08:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2008-06-25 07:02:13 EDT
Description of problem:

When tried to register to EUS channel rhn.redhat.com from default 4.7 Beta
installation and the EUS channel in not on the RHN server, then up2date fails
this way:

[root@dell-pe2900-01 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 7 Beta)

[root@dell-pe2900-01 ~]# rhnreg_ks --username=qa@redhat.com --password=redhatqa
--use-eus-channel --force
While running 'registration.new_system': caught
<type 'instance'> : 'id'


It'll be much more convenient to fail with some human-readable message.

Version-Release number of selected component (if applicable):

4.7.1-17.el4

How reproducible:
always

Steps to Reproduce:
1. install 4.7 beta or other 
2. try to register with CLI tools
3. when the channel's not there (I guess), it fails oddly

Note You need to log in before you can comment on or make changes to this bug.