Bug 452867 - html stylesheet fails
html stylesheet fails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-25 10:30 EDT by oli kron
Modified: 2008-12-18 07:11 EST (History)
1 user (show)

See Also:
Fixed In Version: docbook-style-xsl-1.74.0-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 08:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test document to perform xsl transformation on (188 bytes, text/xml)
2008-06-25 10:30 EDT, oli kron
no flags Details

  None (edit)
Description oli kron 2008-06-25 10:30:49 EDT
Description of problem:

html stylesheet of docbook-style-xsl
(/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl) fails on docbook
books or articles

Version-Release number of selected component (if applicable):

docbook-style-xsl-1.73.2-9.fc9.noarch

How reproducible:

ever and easy

Steps to Reproduce:
1. Create a simple docbook article (e.g. use test.xml attached)
2. run java -jar /usr/share/java/xalan-j2-2.7.0.jar -in test.xml -xsl
/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl -out test.html
  
Actual results:

SystemId Unknown; Line #185; Column #91; XSLT Error
(javax.xml.transform.TransformerConfigurationException):
javax.xml.transform.TransformerException:
javax.xml.transform.TransformerException: org.apache.xpath.functions.FuncConcat
only allows >1 arguments
Exception in thread "main" java.lang.RuntimeException:
javax.xml.transform.TransformerException:
javax.xml.transform.TransformerException: org.apache.xpath.functions.FuncConcat
only allows >1 arguments
        at org.apache.xalan.xslt.Process.doExit(Process.java:1153)
        at org.apache.xalan.xslt.Process.main(Process.java:1126)


Expected results:

No error, test.html created

Additional info:

To exclude a possibility of a bug in xalan-j2, I did the same transformation
using saxon 6.5.5. Saxon generated this error message:

Error at xsl:value-of on line 185 of
file:/usr/share/sgml/docbook/xsl-stylesheets/html/dtbl.xsl:
  Variable relative.widths.total has not been declared
Transformation failed: Failed to compile stylesheet. 1 error detected.

I worked-around this bug by editing
/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl - I removed the line
"<xsl:include href="dtbl.xsl"/>". After this "fix" both xalan-j2 and saxon
worked fine. Anyway I don't think this a correct fix.

docbook-style-xsl-1.73.2-1.fc7.noarch of Fedora 7 was OK.

I seems to me that this bug was introduced by this commit:
http://www.redhat.com/archives/fedora-extras-commits/2007-June/msg03130.html
The commit refers to an upstream but I can't see that change at
http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl (but I'm not
familiar with docbook development).
Comment 1 oli kron 2008-06-25 10:30:49 EDT
Created attachment 310269 [details]
test document to perform xsl transformation on
Comment 2 Ondrej Vasik 2008-06-25 11:07:45 EDT
Thanks for report... the patch was from upstream mailing list -
http://www.oasis-open.org/archives/docbook-apps/200601/msg00155.html - but as is
still not in new version 1.73.3 , it was probably rejected. This patch is fixing
xmlto issue #161619. Will check possible solutions which will work for both sides.
Comment 3 oli kron 2008-06-26 02:27:45 EDT
Hi, thank for taking it!

I haven't permissions to see #161619 - never mind, I'm not actually interested
in the bug per se. What is interesting to me is: If the patch _fixed_ something
then you know a way to run transformations without the failures above - some
option to xalan-j2 or completely different XSLT processor or something like
this... Any tip?

TIA
oli
Comment 4 Ondrej Vasik 2008-06-26 03:44:20 EDT
I'm quiet sure you have permisions to check that bugzilla, only evil AI of
bugzilla added link to internal issue tracker for RHEL's . The original issue
solved by the patch is on https://bugzilla.redhat.com/show_bug.cgi?id=161619 .
Have some other issues in progress, this one is in my todo list - once I will
solve the issues in progress, I will focus on it a bit more. No tips at the
moment, have to look a bit more closely.
Comment 5 oli kron 2008-06-26 05:11:27 EDT
Thanks for the correct link. The XSLT processor used there is xsltproc. I've
tried it - works for me! Thus I'm not sure if my bugreport is more about
docbook-style-xsl or xalan-j2...

Anyway, I'd like to have this solved some day as my work envoronment is heavily
based on java tools (like xalan and saxon).

Thanks for your replies - they helped to find a better workaround for now!

Have a nice day
oli
Comment 6 Kamil Dudka 2008-08-06 08:04:26 EDT
fixed in rawhide - docbook-style-xsl-1.74.0-3.fc10
Comment 7 oli kron 2008-12-18 07:11:36 EST
I've finally upgraded to Fedora 10 and tested your fix. Everything is OK.

Dekuji :-)
Oli

Note You need to log in before you can comment on or make changes to this bug.