Bug 452892 - nouveau ignores DDC modelines greater than panel size
Summary: nouveau ignores DDC modelines greater than panel size
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 16:50 UTC by Josh Cogliati
Modified: 2018-04-11 10:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-21 15:24:44 UTC


Attachments (Terms of Use)
Xorg.conf file used. (650 bytes, text/plain)
2008-06-26 13:52 UTC, Josh Cogliati
no flags Details
Xorg.0.log file when nouveau used with DVI cable. (94.38 KB, text/plain)
2008-06-26 13:53 UTC, Josh Cogliati
no flags Details
Xorg.0.log when no xorg.conf file used (uses nv driver) (42.20 KB, text/plain)
2008-06-26 14:31 UTC, Josh Cogliati
no flags Details

Description Josh Cogliati 2008-06-25 16:50:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
My monitor is a DELL 2001FP that is capable of running at 1600x1200.  However, when connected by a digital cable, nouveau only runs it at 1280x1024.  randr -q does not show the 1600x1200 resolution.  

Partial output from Xorg.0 when connected by a DVI cable:
...
(II) NOUVEAU(0): Serial No: C06464712LLL
(II) NOUVEAU(0): Monitor name: DELL 2001FP
(II) NOUVEAU(0): Ranges: V min: 56 V max: 76 Hz, H min: 31 H max: 80 kHz, PixClock max 162 MHz
(II) NOUVEAU(0): EDID (in hex):
(II) NOUVEAU(0): 	00ffffffffffff0010ac08a04c4c4c32
(II) NOUVEAU(0): 	1b0e010380291f78ee6390a3574b9b25
(II) NOUVEAU(0): 	115054a54b008180a940714f01010101
(II) NOUVEAU(0): 	010101010101483f403062b0324040c0
(II) NOUVEAU(0): 	13006f131100001e000000ff00433036
(II) NOUVEAU(0): 	3436343731324c4c4c20000000fc0044
(II) NOUVEAU(0): 	454c4c203230303146500a20000000fd
(II) NOUVEAU(0): 	00384c1f5010000a2020202020200033
(--) NOUVEAU(0): CRTC 0 is currently programmed for DFP
(II) NOUVEAU(0): Using DFP on CRTC 0
(--) NOUVEAU(0): Panel size is 1280 x 1024
(II) NOUVEAU(0): EDID vendor "DEL", prod id 40968
(II) NOUVEAU(0): Using EDID range info for horizontal sync
(II) NOUVEAU(0): Using EDID range info for vertical refresh
(II) NOUVEAU(0): Printing DDC gathered Modelines:
(II) NOUVEAU(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
...
(II) NOUVEAU(0): Not using default mode "1600x1200" (exceeds panel dimensions)
...

Basically, the panel dimension returned by the monitor seems to be a 'recommended dimension', and the DDC returns other allowable modes that exceed that dimension.  

If I connect the monitor with a analog SUB connecter, I can use the 1600x1200 mode fine.  

Snipped output from Xorg.0 file when using a analog cable:
(II) NOUVEAU(0): Monitor name: DELL 2001FP
(II) NOUVEAU(0): Ranges: V min: 56 V max: 76 Hz, H min: 31 H max: 80 kHz, PixClock max 162 MHz
(II) NOUVEAU(0): EDID (in hex):
(II) NOUVEAU(0): 	00ffffffffffff0010ac07a04c4c4c32
(II) NOUVEAU(0): 	1b0e01030e291f78ee6390a3574b9b25
(II) NOUVEAU(0): 	115054a54b008180a940714f01010101
(II) NOUVEAU(0): 	010101010101483f403062b0324040c0
(II) NOUVEAU(0): 	13006f131100001e000000ff00433036
(II) NOUVEAU(0): 	3436343731324c4c4c20000000fc0044
(II) NOUVEAU(0): 	454c4c203230303146500a20000000fd
(II) NOUVEAU(0): 	00384c1f5010000a20202020202000a6
(--) NOUVEAU(0): CRTC 0 appears to have a CRT attached
(II) NOUVEAU(0): Using CRT on CRTC 0
(II) NOUVEAU(0): EDID vendor "DEL", prod id 40967
(II) NOUVEAU(0): Using EDID range info for horizontal sync
(II) NOUVEAU(0): Using EDID range info for vertical refresh
(II) NOUVEAU(0): Printing DDC gathered Modelines:
(II) NOUVEAU(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)



Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.10-2.20080408git0991281.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Connect DELL 2001FP to card with DVI cable.
2. Try to set resolution to 1600x1200.
3. Only get 1280x1024

Actual Results:
Got 1280x1024 screen resolution.

Expected Results:
Should have gotten 1600x1200 screen resolution.

Additional info:
(--) PCI:*(0@7:0:0) nVidia Corporation G70GL [Quadro FX 4500] rev 161, Mem @ 0xdd000000/16777216, 0xc0000000/268435456, 0xde000000/16777216, I/O @ 0x0000dc80/128, BIOS @ 0x????????/131072

Comment 1 Matěj Cepl 2008-06-26 08:43:10 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Matěj Cepl 2008-06-26 08:46:15 UTC
sorry, don't bother with running Xorg without xorg.conf -- it wouldn't help us
with testing radeonhd driver a bit, because you would get old radeon driver.

Comment 3 Josh Cogliati 2008-06-26 13:52:19 UTC
Created attachment 310331 [details]
Xorg.conf file used.

Comment 4 Josh Cogliati 2008-06-26 13:53:23 UTC
Created attachment 310332 [details]
Xorg.0.log file when nouveau used with DVI cable.

Comment 5 Josh Cogliati 2008-06-26 14:31:38 UTC
Created attachment 310338 [details]
Xorg.0.log when no xorg.conf file used (uses nv driver)

Comment 6 Josh Cogliati 2008-06-26 14:32:55 UTC
Attached the information requested.  I went ahead and ran with no xorg.conf
file.  It used the nv driver, but that driver has the same problem as the
nouveau driver.

Comment 7 Adam Jackson 2008-07-21 15:24:44 UTC
Yes, I know this is against nouveau not nv, but it's the same problem.

*** This bug has been marked as a duplicate of 234824 ***

Comment 8 Josh Cogliati 2008-11-05 17:02:06 UTC
This bug (but not bug 234824 ) is now fixed in Fedora 10 preview release.

Comment 9 Josh Cogliati 2008-12-02 22:26:24 UTC
Fixed in Fedora 10 with xorg-x11-drv-nouveau-0.0.11-1.20080902git6dd8ad4.fc10.x86_64


Note You need to log in before you can comment on or make changes to this bug.