Bug 452898 - path to site_perl uses /usr/local
path to site_perl uses /usr/local
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-25 13:46 EDT by GeoffLeach
Modified: 2008-07-06 02:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.10.0-30.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 02:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GeoffLeach 2008-06-25 13:46:57 EDT
Description of problem:
This version has been compiled to default site_perl to /usr/local/perl5. This
breaks everything and is far to pervasive for a bugfix release

Version-Release number of selected component (if applicable):
perl-5.10.0-26.fc9.i386

How reproducible:
always

Steps to Reproduce:
1.run a perl script that uses a module in site_perl
2.
3.
  
Actual results:
can't find module

Expected results:
finds module

Additional info:
Comment 1 Ed Greenberg 2008-06-25 23:37:07 EDT
All modules installed by CPAN (that which is not available from RPMs) still
reside in /usr/lib/.../site_perl, but the @INC no longer points there. Newly
installed modules from CPAN now go to /usr/local. This requires the system admin
to uninstall/reinstall all perl modules that came from CPAN, or to visit each
script and add a BEGIN {push (@INC,"original path")} 

CPAN script doesn't know about what was previously installed. If I install the
same packages, I get a fresh install rather than "Package::Name is up to date." 

My opinion is that the change is a good one, since CPAN packages will now
survive a re-install of the OS, but rolling this out in a YUM UPDATE without
warning is probably going to break lots of people's stuff, and PLEASE don't
slide this in quietly in RHEL.



Comment 2 Stepan Kasal 2008-06-26 04:06:12 EDT
(In reply to comment #0)
> This version has been compiled to default site_perl to /usr/local/perl5.
> perl-5.10.0-26.fc9.i386

Please note that the previous version was compiled with site_perl under
/usr/local on 64bit systems and under /usr on 32bit systems, as reported in bug
#448735.
The change to /usr/local was intentional and happened before Fedora 9.
Unfortunately, there was a typo which made it ineffective on 32bit systems. This
is why we got half of the systems one way and half of them the other way.

(In reply to comment #1)
> [...] rolling this out in a YUM UPDATE without
> warning is probably going to break lots of people's stuff,

As explained above, the staring position was unfortunate.  But the change was
even more so.  The /usr/lib/.../site_perl has to be added back, for
compatibility, at least on 32bit systems...
But even after that change, the CPAN script will be confused, as it won't know
about /usr/lib/.../site_perl.

> and PLEASE don't slide this in quietly in RHEL.

There is no danger this will creep in to a RHEL Erratum.
Comment 3 Fedora Update System 2008-06-30 09:49:33 EDT
perl-5.10.0-29.fc9 has been submitted as an update for Fedora 9
Comment 4 GeoffLeach 2008-06-30 11:19:02 EDT
I don't wish to seem ungreatful, but anyone who was affected has already made
the necessary adjustments. Please be sure to include /usr/local.../site_perl if
you've switched back to the original configuration so as to not break
installations again.
Comment 5 Fedora Update System 2008-07-01 01:25:09 EDT
perl-5.10.0-29.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5875
Comment 6 Stepan Kasal 2008-07-01 05:53:11 EDT
(In reply to comment #4)
> I don't wish to seem ungreatful, but anyone who was affected has already made
> the necessary adjustments. Please be sure to include /usr/local.../site_perl if
> you've switched back to the original configuration so as to not break
> installations again.

The main site dir is still /usr/local/lib.  The change appends an additional
/usr/lib/.. to the end of the @INC path.  The effect for those who switched
should thus be minimal.  But it should ease the setup for those who have not yet
consumed the previous update.
Comment 7 Fedora Update System 2008-07-06 02:17:26 EDT
perl-5.10.0-30.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.