Bug 452952 - client lib picks up dependency on xqilla and xerces-c
client lib picks up dependency on xqilla and xerces-c
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
high Severity medium
: Next Version
: ---
Assigned To: Matthew Farrellee
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-26 04:16 EDT by Gordon Sim
Modified: 2011-08-12 12:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 09:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-06-26 04:16:15 EDT
From Ted Ross:

"Looking at the qpidc package, it appears that it has dependencies on xqilla and
xerces.  Surely this is an error, is it not?"

From Matt Farrellee:

"configure.ac checks for xqilla and xerces-c with AC_LIB_CHECK, so if they are
found -lxqilla and -lxerces-c will be used on all link lines. Now, we're
building in brew so no extra xqilla or xerces-c libraries should be installed,
but they are installed because qpidd is built from the same spec as qpidc and it
requires them.

The solution to this may be to not just throw -lxqilla etc (likely same issue
with -lsasl2) in LIBS, but to keep them separate and only use them when building
a binary that needs them. There must be a simpler solution though."
Comment 1 Matthew Farrellee 2008-06-26 09:03:39 EDT
Upstream...

https://issues.apache.org/jira/browse/QPID-1151

Note You need to log in before you can comment on or make changes to this bug.