Bug 452962 - Update periodically "External Bugzilla References" with the current state of the upstream bugs
Update periodically "External Bugzilla References" with the current state of ...
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
: FutureFeature
Depends On:
Blocks: 189813
  Show dependency treegraph
 
Reported: 2008-06-26 05:43 EDT by Matěj Cepl
Modified: 2014-10-12 18:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-20 06:49:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-06-26 05:43:06 EDT
Description of problem:
Given that many non-RH have now XML-RPC interfaces as well, it should be
possible to at least provide get status of all upstream bugs and display it in
the External Bugzilla References.

Seems to me much possible than overambitious bug 189813 (which needs to be fixed
as well, but it will take much more time and effort).
Comment 1 David Lawrence 2008-06-26 17:53:22 EDT
This was the original intent at the time the feature was added. The status
updates are dependent on the other tracking system supporting the same XMLRPC
API and at the time Red Hat's Bugzilla was the only one who had that support.
With the release of upstream Bugzilla 3.0 and soon to be released 3.2 there is
now pretty standard API for getting information about a bug report given a bug
id and that the bug is publicly accessible. After we get 3.2 out here we will
work on this feature and start utilizing the standard API. 

We will also need to discuss things like caching results, etc. since having to
update the status each time a bug is displayed may turn out to be a performance
hit. Especially if a single bug report has many external references.

This is still very Bugzilla centric and will not work for other tracking systems
even though you can still add their bugs as a reference.

Dave
Comment 2 Matěj Cepl 2008-06-27 07:59:41 EDT
(In reply to comment #1)
> This is still very Bugzilla centric and will not work for other tracking
> systems even though you can still add their bugs as a reference.

Probably, but a) I believe that still majority of our upstream bugs are
bugzillas (and maybe even bugzillas >= 3.*), b) it is worthy to have at least
the implementation of our side ready and then we could just add some more
connectors for non-bugzilla bug repositories.
Comment 3 David Lawrence 2008-06-27 13:38:04 EDT
(In reply to comment #2)
> Probably, but a) I believe that still majority of our upstream bugs are
> bugzillas (and maybe even bugzillas >= 3.*), b) it is worthy to have at least
> the implementation of our side ready and then we could just add some more
> connectors for non-bugzilla bug repositories.

Agreed and is part of our plan. We will try to access the remote site in an eval
block and if it works show the current bugs status and summary.

Comment 4 Juha Tuomala 2009-04-23 07:30:18 EDT
related bug 189813
Comment 5 Matěj Cepl 2009-06-03 05:01:34 EDT
(In reply to comment #1)
> We will also need to discuss things like caching results, etc. since having to
> update the status each time a bug is displayed may turn out to be a performance
> hit. Especially if a single bug report has many external references.

Actually, this could be quite easily just some daily cron job IMHO ... it may not be that important if this information is accurate just as of last 24 hours. What do you think?
Comment 6 David Lawrence 2009-06-03 12:01:59 EDT
A cron job could be used. I was originally thinking more off just storing a timestamp along with the db bug mapping that the Bugzilla code can use to determing the last time the data was refreshed. 24hours sounds reasonable.

Note to self: also along with the last_refreshed timestamp, also need to add bug status and summary columns to the db mapping table.
Comment 7 David Lawrence 2010-01-15 12:32:16 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 8 Matěj Cepl 2010-01-16 02:04:49 EST
Of course, this is very much alive.

(BTW, you should needinfo flag on these requests for retesting)
Comment 9 David Lawrence 2010-08-25 17:42:34 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 10 Matěj Cepl 2010-08-26 06:21:48 EDT
Comment 8 applies here without any change in all its parts :) (still no needinfo used)
Comment 11 David Lawrence 2010-08-26 13:27:05 EDT
This feature is coming soon as it is a requirement for our current JIRA to Bugzilla migration efforts. 

https://bugzilla.redhat.com/show_bug.cgi?id=619547

You can see work so far installed on our test server at https://bz-web2-test.devel.redhat.com

I only have the functionality enabled for bugzilla.redhat.com and jira.jboss.org attached references at this time. I can add in others such as mozilla.bugzilla.org and any others running at least 3.0 or higher.

Dave
Comment 12 Matěj Cepl 2010-08-26 18:34:34 EDT
(In reply to comment #11)
> I only have the functionality enabled for bugzilla.redhat.com and
> jira.jboss.org attached references at this time. I can add in others such as
> mozilla.bugzilla.org and any others running at least 3.0 or higher.

That's a great news!

Certainly my personal preferences would be https://bugzilla.mozilla.org and https://bugs.freedesktop.org, but I guess others will want something (from the huge projects at least https://bugzilla.kernel.org/). All of these have at least 3.* bugzillas. Are there any statistics on number of external references in our bugzilla by external bugzilla?

And how does it relate to "See Also" field?

Note You need to log in before you can comment on or make changes to this bug.