Bug 453005 - pm-utils has unnecessary Requires on kbd
pm-utils has unnecessary Requires on kbd
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-26 11:41 EDT by Chris Lalancette
Modified: 2015-03-04 20:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 12:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove unnecessary kbd dependency from pm-utils (957 bytes, patch)
2008-06-26 11:41 EDT, Chris Lalancette
no flags Details | Diff

  None (edit)
Description Chris Lalancette 2008-06-26 11:41:29 EDT
Description of problem:
As part of oVirt (http://ovirt.org), we need to use hal on our embedded node
image.  The hal package pulls in pm-utils, which pulls in the kbd package. 
However, it looks like based on the ChangeLog in the top level of the source tree:

    remove sysfont wrapper call. no other distro from fedora uses it
    
    On Jan 28, 2008 11:31 AM, Dan Nicholson <dbn.lists@gmail.com> wrote:
    > On Jan 27, 2008 9:42 PM, Vasiliy G Tolstov <v.tolstov@selfip.ru> wrote:
    > > Gentoo does not have this utilities. Default gentoo init script that
    > > setting console font executes /bin/setfont
    >
    > That's because setsysfont is a Fedora specific wrapper script around
    > setfont in their initscripts package.
    >
    >
http://cvs.fedoraproject.org/repo/pkgs/initscripts/initscripts-8.60.tar.bz2/a0e888cc91ef6350a991985567d21366/initscripts-8.60.tar.bz2
    
    In that case...
    
    Patch attached to remove 60sysfont.  setsysfont is Fedora-specific,

So I think the kbd dependency is no longer needed for pm-utils.  This will save
us 2MB of disk-space, which is important since we are trying to keep the
compressed size of the node < 64MB.

Attached is a simple spec file patch to do just this.
Comment 1 Chris Lalancette 2008-06-26 11:41:29 EDT
Created attachment 310345 [details]
Patch to remove unnecessary kbd dependency from pm-utils
Comment 2 Till Maas 2008-06-26 12:17:35 EDT
pm-utils uses chvt, which is in kbd, therefore the dependency is still needed.
Maybe you can get chvt seperated from kbd, but currently I do not see a way to
get rid of the kbd dependency.
Comment 3 Till Maas 2008-07-02 04:21:47 EDT
Maybe the usage of chvt in pm-utils will be removed by upstream soon, when this
happens and the version hits Fedora, the kbd dependency will be dropped.

Note You need to log in before you can comment on or make changes to this bug.