Bug 453070 - boot.iso: anaconda is not setting domain in resolve.conf for net install
Summary: boot.iso: anaconda is not setting domain in resolve.conf for net install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 03:10 UTC by Jens Petersen
Modified: 2008-08-26 21:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-26 21:22:40 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-06-27 03:10:36 UTC
Description of problem:
When using boot.iso to do a net install the domain does not get set from dhcp.
This means that the host in the url to the repo needs to be fully-qualified.

Version-Release number of selected component (if applicable):
anaconda-11.4.1.9-1.x86_64

How reproducible:
every time

Steps to Reproduce:
1. install rawhide from boot.iso
2. on repos screen edit Fedora Rawhide repo to use a local baseurl:
 eg http://download/pub/fedora/rawhide-x86_64
3. continue install
  
Actual results:
No domain set in resolve.conf so anaconda attempts 10 times
but repo can't be accessed.

Expected results:
Set domain name in resolve.conf or complain that host/repo can't be found.

Additional info:
Also it would be nice if the local mirror could be set before anaconda retrieves any
info for "Fedora - Rawhide" from fedora mirrors, but I guess that deserves a
separate bug.

Comment 1 Jens Petersen 2008-07-02 03:36:44 UTC
After complaining that the host or repo is unreachable there should be
an opportunity to edit the repo configuration to correct any mistake in the urls.

Comment 2 Chris Lumens 2008-08-26 21:22:40 UTC
This should be fixed in the next build of anaconda because of David's NetworkManager patches against rawhide.


Note You need to log in before you can comment on or make changes to this bug.