Bug 453140 - Boot fail on MS Virt PC ("Volgroup00" not found)
Boot fail on MS Virt PC ("Volgroup00" not found)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-27 10:43 EDT by Miroslav Pragl
Modified: 2008-07-31 11:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 11:25:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Pragl 2008-06-27 10:43:56 EDT
Description of problem:
This must be some BFM but after couple of updates F9 doesn't boot on MS Virtual 
PC 2007:

Red Hat nash version 6.0.52 starting 
Reading au physical volunes. This may take a while... 
No volume groups found 
Volume group "VolGroupOO" not found 
Unable to access resume device (/dev/VolGroup00/LogVol0l)
mount: could not find filesystem '/dev/root'
setuproot moving /dev failed: No such file or directory 
setuproot error mounting /proc: No such file or directory
setuproot error mounting /sys: No such file or directory
Mount failed for selinuxfs on selinux: No such file or directory
switchroot: mount failed: No such file or directory 

After 2-5 warm resets booting succeedes !!! 



Version-Release number of selected component (if applicable):
2.6.25.6-55

How reproducible:
80% of boots

Steps to Reproduce:
1. Start virtual machine
2. Sit and watch boot logging 
3.
  
Actual results:
Boot

Expected results:
Failed boot

Additional info:
Are there any kernel switches to try? I obviously use "noreplace-paravirt".
Comment 1 Miroslav Pragl 2008-06-27 10:49:28 EDT
sorry, few more comments:


- i just noticed (the failed boot is way too fast) that _no harddrives are 
actually detected_ - too sort probe timeout or something like that?

- since this stared happening i can't poweroff the (virtual) machine, it halts 
instead

- fsck found no problems (as expected)

MP
Comment 2 Miroslav Pragl 2008-06-27 11:26:37 EDT
looks like

 acpi=off 

does the trick, let me test it

MP
Comment 3 Miroslav Pragl 2008-07-31 11:25:36 EDT
confirmed

MP

Note You need to log in before you can comment on or make changes to this bug.