Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 453223 - Closing lid on Dell Latitude D820 crashes X
Summary: Closing lid on Dell Latitude D820 crashes X
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server
Version: 5.2
Hardware: i686
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 21:21 UTC by Greg Bailey
Modified: 2012-04-17 21:24 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-17 21:06:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
output of dmidecode (15.05 KB, text/plain)
2008-06-27 21:21 UTC, Greg Bailey
no flags Details
xorg.conf (1.37 KB, text/plain)
2008-06-27 21:22 UTC, Greg Bailey
no flags Details
Xorg.0.log (34.45 KB, text/plain)
2008-07-01 16:46 UTC, Greg Bailey
no flags Details


Links
System ID Private Priority Status Summary Last Updated
CentOS 2910 0 None None None Never

Description Greg Bailey 2008-06-27 21:21:33 UTC
Description of problem:

This bug is opened at the request of CentOS developers.  Closing the lid and
then reopening on Dell Latitude D820 gives X backtrace. This was working with
CentOS 5.1, so it appears to be a regression. It happens with both the "i810"
and the new, experimental "intel" driver.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.1.1-48.41.el5_2.1

How reproducible:

Always

Steps to Reproduce:
1.  Start X session (startx)
2.  Close lid of notebook
3.  Open lid and observe backtrace
  
Actual results:

The following was observed on the screen:

SetGrabKeysState - disabled
SetGrabKeysState - enabled
I830PMEvent: Capability change

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80c3701]
1: [0xe29420]
2: /usr/lib/xorg/modules/drivers/intel_drv.so [0x5cc06b]
3:
/usr/lib/xorg/modules/drivers/intel_drv.so(intel_xf86InitialConfiguration+0xf2a)
[0x5cf3da]
4: /usr/lib/xorg/modules/drivers/intel_drv.so [0x5ad0a0]
5: /usr/bin/X [0x80e2b13]
6: /usr/bin/X(xf86HandlePMEvents+0xb5) [0x80e2c75]
7: /usr/bin/X(xf86Wakeup+0x153) [0x80c4bc3]
8: /usr/bin/X(WakeupHandler+0x59) [0x808c229]
9: /usr/bin/X(WaitForSomething+0x1b9) [0x81a0d79]
10: /usr/bin/X(Dispatch+0x8d) [0x808804d]
11: /usr/bin/X(main+0x485) [0x806fab5]
12: /lib/libc.so.6(__libc_start_main+0xdc) [0x140dec]
13: /usr/bin/X(FontFileCompleteXLFD+0x1ed) [0x806edb1]

Fatal server error:
Caught signal 11.  Server aborting

xinit:  connection to X server lost.

Expected results:

Working X11 session

Additional info:

Please see attached files:  dmidecode output and xorg.conf

Comment 1 Greg Bailey 2008-06-27 21:21:33 UTC
Created attachment 310482 [details]
output of dmidecode

Comment 2 Greg Bailey 2008-06-27 21:22:16 UTC
Created attachment 310483 [details]
xorg.conf

Comment 3 Greg Bailey 2008-06-27 21:23:15 UTC
External bug reference:
http://bugs.centos.org/view.php?id=2910

Comment 4 Matěj Cepl 2008-07-01 14:27:44 UTC
Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as
individual uncompressed file attachment using the bugzilla file attachment link
below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 5 Greg Bailey 2008-07-01 16:46:58 UTC
Created attachment 310692 [details]
Xorg.0.log

Comment 6 Adam Jackson 2012-04-17 21:06:37 UTC
This is almost certainly fixed in 5.2 or later, significant updates to the i810 driver happened since 5.1.  However, no further hardware enablement updates are planned for RHEL5's X stack.  If this issue is still present in RHEL6, please update the affected product version and reopen this bug.

Comment 7 Greg Bailey 2012-04-17 21:24:25 UTC
Correct; the Dell Latitude D820 has since been reloaded with RHEL 6, and the OS suspends correctly when the lid is closed; the kernel panic no longer occurs.


Note You need to log in before you can comment on or make changes to this bug.