Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 45324 - XFree86-4.1.0-0.5.9 requires Mesa-3.4.2-0.410.2 and vice-versa
XFree86-4.1.0-0.5.9 requires Mesa-3.4.2-0.410.2 and vice-versa
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-06-21 07:57 EDT by Josi Romildo Malaquias
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-24 15:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Josi Romildo Malaquias 2001-06-21 07:57:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I was unable to rebuild the XFree86-4.1.0-0.5.9 package because it requires
Mesa >= 3.4.2-0.410.2 and Mesa-3.4.2-0.410.2 cannot be installed because it
requires XFree86 >= 4.1.0.

This is in a Red Hat Linux 7.1 system with updates.
I need to rebuild XFree86 because the binaries from
Raw Hide depends on a new glibc library.

How reproducible:

Steps to Reproduce:
1. rpm -Fvh XFree86*-4.1.0-0.5.9.i386.rpm
2. rpm -Fvh Mesa*-3.4.2-0.410.2.i386.rpm
3. rpm --rebuild XFree86-4.1.0-0.5.9.src.rpm

Actual Results:  1. Error message:
   Mesa >= 3.4.2-0.410.2 is needed by XFree86-4.1.0-0.5.9

2. Error message:
   XFree86 >= 4.1.0 is needed by Mesa-3.4.2-0.410.2

3. Error message:
   error: failed build dependencies:
        Mesa-devel >= 3.4.2-0.410.2 is needed by XFree86-4.1.0-0.5.9

Expected Results:  1.
3. Rebuilt the XFree86-4.1.0-0.5.9 package

Additional info:
Comment 1 Joe Krahn 2001-06-21 09:49:21 EDT
I think all you need is to install XFree86+Mesa on
the same rpm command. Try:

>rpm -Fvh XFree86*-4.1.0-0.5.9.i386.rpm Mesa*-3.4.2-0.410.2.i386.rpm

Instead of:
>rpm -Fvh XFree86*-4.1.0-0.5.9.i386.rpm
>rpm -Fvh Mesa*-3.4.2-0.410.2.i386.rpm

Joe Krahn
Comment 2 Josi Romildo Malaquias 2001-06-21 10:05:48 EDT
Installing both packages at once with

  rpm -Fvh XFree86*-4.1.0-0.5.9.i386.rpm Mesa*-3.4.2-0.410.2.i386.rpm

would be the solution for the binary packages mutual dependency, if the XFree86
packages did not depend on a new glibc binary package that I do not want to have
installed in my system. The above command gives me

  libc.so.6(GLIBC_2.2.3)   is needed by XFree86-libs-4.1.0-0.5.9

That is the reason for rebuilding the packages. But their building seems to be
mutually dependent, as described.
Comment 3 Alexei Podtelezhnikov 2001-06-24 15:34:35 EDT
Once you start using rawhide, go ahead and update your glibc to 2.2.3-11
I breaks nothing for me under RH 7.1
Comment 4 Mike A. Harris 2001-07-12 19:16:15 EDT
Install glibc 2.2.3 first, then XFree86 and Mesa.  Do not use 0.5.9 though.
You will not get what you are looking for.  Nobody should use XFree86-4.1.0 less
than release 0.8.6.  Wait until it is in rawhide and use it.

The build dependancy will *NOT* ever be fixed.  For details, query bugzilla as I
have said it to many times.  Mesa is going away completely in the future.

Note You need to log in before you can comment on or make changes to this bug.