Bug 453247 - cannot install apps with gpk-application in VNC session
cannot install apps with gpk-application in VNC session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 452048 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-28 06:55 EDT by Gian Piero De Lolliis
Modified: 2008-10-27 09:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:08:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Piero De Lolliis 2008-06-28 06:55:13 EDT
Description of problem:
gpk-application do not permit to install package (install icon is gray) in a VNC
session.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.12-12.20080430.fc9.i386

How reproducible:
Using gpk-applicaton inside a VNC session

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2008-06-29 03:04:41 EDT
mcabber-0.9.7-1.fc9 has been submitted as an update for Fedora 9
Comment 2 Fedora Update System 2008-06-29 18:00:35 EDT
mcabber-0.9.7-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mcabber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5840
Comment 3 Gian Piero De Lolliis 2008-07-01 02:18:29 EDT
Hi,
mcabber is a instant messagging client, what got with packagekit?

Kind regards,
MT
Comment 4 Richard Hughes 2008-07-04 05:58:58 EDT
Nothing, I think FUS has got the bug number wrong :-)

Your problem is due to the vnc client not registering with ConsoleKit I guess.
In the vnc session can you do ck-list-sessions please, and paste the output. Thanks.
Comment 5 Gian Piero De Lolliis 2008-07-04 14:41:17 EDT
I'm actually using UltraVNC client (under Windows v. 1.1.0.4)

The command output is:
# ck-list-sessions 
Session1:
	uid = '0'
	realname = 'root'
	seat = 'Seat2'
	session-type = ''
	active = FALSE
	x11-display = ':1'
	x11-display-device = ''
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-07-04T17:41:09Z'
Session2:
	uid = '500'
	realname = ''
	seat = 'Seat3'
	session-type = ''
	active = FALSE
	x11-display = ':2'
	x11-display-device = ''
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-07-04T17:41:11Z'

Kind regards,
MT
Comment 6 Richard Hughes 2008-08-18 05:06:37 EDT
Right, the active = FALSE tells PackageKit you're not actually on console.
Comment 7 Richard Hughes 2008-10-27 09:08:05 EDT
I've added a warning in the current rawhdie version, although this is actually a vnc bug IMO.
Comment 8 Richard Hughes 2008-10-27 09:13:06 EDT
*** Bug 452048 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.