Bug 45325 - Xconfigurator should set DisplaySize
Xconfigurator should set DisplaySize
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-21 08:26 EDT by Jonathan Kamens
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-03 01:36:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-06-21 08:26:55 EDT
The X server can't figure out what the resolution of a monitor is if the
DisplaySize parameter isn't set in XF86Config.  When it has to guess, it
usually guesses 75dpi instead of 100dpi, which (a) is questionable given
the high resolution of most modern monitors and (b) makes fonts and such
look really awful.

The database used by Xconfigurator should have monitor sizes and add them
automatically to the generated XF86Config.  For database entries that don't
have a monitor size, Xconfigurator should prompt for it.
Comment 1 Mike A. Harris 2002-11-03 01:36:45 EST
IMHO users should never ever _have_ to configure something like this.
It should be autodetected wherever possible, and default to something
minimally sane elsewhere.  Forcing DPI setting, or even presenting
it somewhere by default is an overcomplexity IMHO that a user shouldn't
need to see.

It is however questionable wether 75dpi is a sane default or not.  It
is the X server itself which chooses 75dpi however.  Basically DDC probe
sets the DPI.  If DDCprobe fails, or if a user supplies DPI info, then
the commandline or config file take precedance.

Not sure if this belongs in the X config tool or not right now, but
I don't have a 100% hard opinion on it yet either.  Plus X has changed
quite a bit since this was filed, and X will be changing even more
yet to come.

I'll reassign this to redhat-config-xfree86 for now.
Comment 2 Alexander Larsson 2002-11-05 07:16:04 EST
redat-config-xfree86 allows you to set the DPI (display size), and it defaults
to using what DDC probes.

Note You need to log in before you can comment on or make changes to this bug.