Bug 4533 - kernel /boot/vmlinuz2.2.11 is too big
kernel /boot/vmlinuz2.2.11 is too big
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-15 12:01 EDT by leo.juno
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-18 12:11:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leo.juno 1999-08-15 12:01:00 EDT
I recently but the last distribution of RedHat 6.0 and I've
got some problem that I never have before under redhat
caldera and Slackware some can you help me please.
After build a new kernel (it's not the first one I build but
it's the first I do under RedHat 6.0) so, after I build the
kernel and install it lilo let me know that the kernel is
too big.
The message is this one:
---------------------------------------------------------
kernel /boot/vmlinuz2.2.11 is too big
ls -l
-rw-r--r-- 1 root root 523538 Aug 15 08:40 vmlinuz-2.2.11
---------------------------------------------------------
I try the patch but it doesn't work I don't know why^
Comment 1 rodrigob 1999-08-18 09:09:59 EDT
That is no big deal. I got that message a lot. It means what it's
saying: the kernel is too big. If you are doing:
# make
try
# make zImage
or
# make bzImage
if you are doing
# make lilo
try
# make zlilo
or
# make bzlilo
(not sure if this last one exists).
I usualy do:
# make bzImage
and install the image myself.
That should solve your problems but, if even using bz you get this
message, consider using modules for some of the kernel options.
Best Regards,
Rodrigo
Comment 2 Zachary Amsden 1999-12-05 14:09:59 EST
There is a definite bug here, it occurs randomly, even when all all cylinder
numbers are below BIOS limits and kernel size is around 400k.

I suspect this is triggered when the kernel is highly fragmented, a couple quick
hacks to lilo to add debugging output showed showed number of sectors required
growing to around 3000 with a 400k kernel.

I don't know too much about lilo internals yet, so unfortunately I don't have a
patch.
Comment 3 Riley H Williams 1999-12-05 15:38:59 EST
I've seen some suggestions somewhere that this bug is connected with the heap
size, and is due to the kernel's uncompressor needing more heap space than is
allocated. Perhaps somebody could look into this?

Note You need to log in before you can comment on or make changes to this bug.