This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 453311 - pulseaudio does not start
pulseaudio does not start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
http://nopaste.linuxgaming.de/1c408fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-29 11:11 EDT by Stefan Posdzich
Modified: 2008-11-04 12:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 12:13:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Posdzich 2008-06-29 11:11:43 EDT
From Bugzilla Helper:
User-Agent: Opera/9.51 (X11; Linux ppc64; U; de)

Description of problem:
Playstation 3 | Fedora 9 | PowerPC

Output when i try to start pulseaudio:

pulseaudio -vv
http://nopaste.linuxgaming.de/1c408fb464.html

Version-Release number of selected component (if applicable):
pulseaudio-0.9.10-1.fc9.ppc

How reproducible:
Always


Steps to Reproduce:
1. Start pulseaudio -> pulseaudio -vv

Actual Results:
See the output

Expected Results:
Pulseaudio startup

Additional info:
Comment 1 Rudolf Kastl 2008-06-29 11:56:49 EDT
i can reproduce that on a foreign ps 3 with fedora 9 installed.
Comment 2 Rui Matos 2008-06-30 13:07:51 EDT
Should probably be marked as a dup of #444684.
Comment 3 Rudolf Kastl 2008-06-30 16:29:25 EDT
#2 from my personal feeling and from reading the target report it seems to be
that it is more likely to be not a dupe.

how do you come to the conclusion?

kind regards,
Rudolf Kastl
Comment 4 Rudolf Kastl 2008-06-30 16:35:47 EDT
is there any more information required? want a backtrace?
Comment 5 Stefan Posdzich 2008-06-30 16:57:40 EDT
Here some more information...

gdb:

http://nopaste.linuxgaming.de/cecbad8197.html
Comment 6 Lennart Poettering 2008-07-01 20:13:41 EDT
This is very likely an ALSA bug. This assert just checks if when we access the
mmap'ed DMA buffer the data is actually aligned whith channels interleaved. That
check fails, Which means there is something wrong with the information ALSA gave
us first. We ask for SND_PCM_ACCESS_MMAP_INTERLEAVED. Apparently ALSA didn't
give us that, but something that resembles more SND_PCM_ACCESS_MMAP_COMPLEX. But
it said it gave us _INTERLEAVED. If alsa lies to us we hit this assert. 

Reassigning to the kernel, because this most likely the alsa kernel drivers need
fixing.
Comment 7 Jaroslav Kysela 2008-11-04 12:13:24 EST
This problem should be fixed in 1.0.17 alsa-lib update package.

Note You need to log in before you can comment on or make changes to this bug.