Bug 453318 - samba F9 to F9 directory copying permission denied.
samba F9 to F9 directory copying permission denied.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-29 12:42 EDT by martin coker
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-07 06:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description martin coker 2008-06-29 12:42:51 EDT
Description of problem:
Just set up another F9 box and have the strangest little niggle I have just come
across.

Both boxes see each other and the shares are browseable no problems. I can
select a file and copy it from one machine to another to a location I require.
Yet if I attempt to do this at directory level from either I get permission denied.

For example I samba shared directory /backup and in it I have a directory /data
. I am just not able to copy the directory /data to the other F9 desktop or any
other location I want. This is the same for each machine. I have checked all
permissions etc and everything is fine. I can copy directories from any of the
windows boxes to each of the F9's just fine. It is only a F9 to F9 problem.

 I have no errors in logs to follow. Nothing is giving me a clue as to what is up.

This is not really a major hassle as strange as it may seen if I mount a network
share of the other F9 in the F9 I am working on. I can drop and drag directories
in no problem to that other F9 no problem. Then going to the other box I can
then move the directory to the location I require from its samba share. I cannot
just mount another F9 share and drop and drag a directory from it to say my home
folder or desktop directly

Version-Release number of selected component (if applicable):
Latest 3.2.0-1 rc1.15 x86_64 samba suite 
one on amd64 and other on intel duo

How reproducible:
As above everytime

Steps to Reproduce:
1.mount another F9 samba share and locate directory to copy
2.drop and drag to say home folder or desktop
3.
  
Actual results:
Permission denied

Expected results:
Should copy directory and contents to the desired location

Additional info:
I have another F8 i386 machine and this is ok with both F9's.So I cannot say if
this is a x86_64 only issue or not. As I say it is just the F9's do not want to
share at directory level with each other.
Comment 1 Guenther Deschner 2008-06-30 17:02:19 EDT
Can you please specify a bit more what you mean with mounting ? Is this a
problem using mount.cifs, gnome/libsmbclient or Windows Explorer ? Thanks.
Comment 2 martin coker 2008-07-01 06:08:43 EDT
Basically there is no problem with mounting the shares at all. 
Suppose I have a samba share directory named /alldatafiles and in this directory
I have a directory /backupconffiles on one of the F9 boxes.
 
Working on the other F9 I  have no problem accessing the share for browsing and
it is possible to copy individual files from the this remote F9 samba directory
with no problem at all. 

However the big problem comes if I just want to copy over a whole directory.
Taking the above example
remote F9 samba share file /alldatafiles/backupconffiles/somebackup.conf
absolutely no problem at all.

But remote F9 samba share directory /alldatafiles/backupconffiles will not work
permission denied.
I have checked all the permissions out but all ok. This happens no matter which
from which F9 I try.

However If working on one F9 I open a remote samba share on the other F9 I can
copy directories in ok. Then as I say just go to the other machine to move the
directory to where I would like it.

The problem is that the F9 will not allow copying of remote samba share
directories to any location apart from another samba share. It will not allow
remote directories to be copied to say the desktop.

This does not however apply to individual files. 
Also the F8 has no problem I can transfer say:
 remote F9 samba share /alldatafiles/backupconffiles
will copy to any location on the F8 I like.(permissions granted).

I only came across this as I have some large directories containing music files
and needed /wanted to transfer them from my old F9 sambashare media directory to
the myhome/music directory on the new F9. I have no problems with any file it is
just working from the new F9 I could not just copy over a folder containing all
an artists albums.

Sorry If this is confusing I believe I could have explained this better. This
may be a case of I know what I mean but just cannot get it in the right terms.
Anyway I will be away for a couple of days. If I can give any more info or you
want me to try anything I will be back on friday
Comment 3 Simo Sorce 2008-07-01 09:08:13 EDT
Martin, 
we understand the description of the problem.
What we need to know is *how* the other share is mounted.
Are you just browsing the other server via Nautilus (the file browser) ?
Have you explicitly mounted the share using mount.cifs ?

Please explain exactly how you "mounted" the other F9 share.
Comment 4 martin coker 2008-07-04 07:52:03 EDT
Sorry I did not clearly understand. Yes I am using nautilus to browse the shares
in all machines. Once I double click on to the share it gets mounted to my gnome
desktop OK in the F9's and also shows in the computer nautilus directory ok. I
did not think to try the command line for this.
Comment 5 martin coker 2008-07-04 08:16:57 EDT
I have just tried tried to mount a folder using places> connect to server in
gnome It throws up unable to mount the folder however it will mount up the
actual share.
I used the following 
server:  LINSERVER
share: All_Music
folder: Artists_A
But as above it would not mount.
I cannot find any error messages in the logs that have been generated. If you
have a log location that I may be missing that may be relevent please advise.
Samba logs are enabled but nothing is shown. 
If you can give me the command line for above to mount I will try it in terminal
if that would help. 
I am a little confused as from a previous bug I understand that gnome is now
using a new file system gvfs. Although from the terminal I believe this would
not be applicable?
 
Comment 6 martin coker 2008-07-07 06:39:25 EDT
I have just updated gvfs : Jul 07 10:33:02 Updated: gvfs-0.2.5-1.fc9.x86_64 and
the problem now seems to be fixed. I can now drag directories over ok between
F9,s. Many thanks changing to fixed

Note You need to log in before you can comment on or make changes to this bug.