Bug 453366 - X locks on boot with 82G33/G31 Express Integrated Graphics Controller
X locks on boot with 82G33/G31 Express Integrated Graphics Controller
Status: CLOSED DUPLICATE of bug 446620
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 02:09 EDT by Chris Sorisio
Modified: 2008-09-02 08:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 08:19:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log for failed boot attempt (21.32 KB, text/plain)
2008-06-30 02:09 EDT, Chris Sorisio
no flags Details
lspci output (2.06 KB, text/plain)
2008-06-30 02:10 EDT, Chris Sorisio
no flags Details
Xorg log for failed boot attempt using xorg-x11-drv-i810-2.3.2-2.fc9.x86_64 (21.53 KB, text/plain)
2008-07-02 21:32 EDT, Chris Sorisio
no flags Details

  None (edit)
Description Chris Sorisio 2008-06-30 02:09:17 EDT
I performed a fresh install of Fedora 9.  System booted to user final steps
menu, but screen locked when X booted for user logon.

I have to boot in text mode and run startx manually.

System worked fine under Fedora 8.  lspci and xorg output attached.
Comment 1 Chris Sorisio 2008-06-30 02:09:17 EDT
Created attachment 310562 [details]
xorg log for failed boot attempt
Comment 2 Chris Sorisio 2008-06-30 02:10:28 EDT
Created attachment 310563 [details]
lspci output
Comment 3 Matěj Cepl 2008-06-30 15:00:18 EDT
Lovely crash in
/usr/lib64/xorg/modules/drivers//intel_master_drv.so(I830WaitLpRing+0x1c1) 
Comment 4 Chris Sorisio 2008-07-02 21:32:04 EDT
Created attachment 310872 [details]
Xorg log for failed boot attempt using xorg-x11-drv-i810-2.3.2-2.fc9.x86_64
Comment 5 Chris Sorisio 2008-07-02 21:33:01 EDT
I updated to xorg-x11-drv-i810-2.3.2-2.fc9.x86_64 to see if that would resolve
my issue.  X no longer failed silently, but instead displayed smeared screen,
then reset, smeared screen, reset, repeat.  If I boot into run mode 3 and
startx, it works fine.  Latest xorg log attached.
Comment 6 Chris Sorisio 2008-07-02 23:07:06 EDT
This bug may be a dupe of 446620.  Booting without rhgb gets me into runlevel 5
as expected, and it leaves the video memory uncached.
Comment 7 Chris Sorisio 2008-08-01 17:39:50 EDT
Could this be related to the Foxconn/AMI BIOS issues?

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/251338
Comment 8 Matěj Cepl 2008-09-02 08:19:51 EDT
(In reply to comment #6)
> This bug may be a dupe of 446620.  Booting without rhgb gets me into runlevel 5
> as expected, and it leaves the video memory uncached.

You are probably right. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 446620 ***

Note You need to log in before you can comment on or make changes to this bug.