Bug 4534 - pump doesn't retrieve DNS server info when using DHCP
pump doesn't retrieve DNS server info when using DHCP
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-08-15 12:17 EDT by gzou
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-17 12:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description gzou 1999-08-15 12:17:32 EDT
pump doesn't retrieve DNS server ip address - no
/etc/resolve.conf is generated. As a consequence, a linux
box using DHCP protocol could not lookup internet address by
hostname. However, dhcpcd, which pump is supposed to
replace, generates /etc/resolve.conf automatically.  pump
(or any startup scripts that use pump) should be modified to
do the same.
Comment 1 David Lawrence 1999-08-17 12:35:59 EDT
This used to be a problem with earlier versions of the pump packages
as orginally shipped with 6.0. It has been fixed in the latest
release. Please download and install the latest pump rpm


Please reopen this report if the problem continues.

Note You need to log in before you can comment on or make changes to this bug.