Bug 453445 - Problems with suspend/resume in RHEL5.2
Problems with suspend/resume in RHEL5.2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
i386 Linux
low Severity medium
: rc
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 13:51 EDT by Homayoun Shahri
Modified: 2015-12-10 10:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 06:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (63.65 KB, text/plain)
2008-07-10 13:31 EDT, Homayoun Shahri
no flags Details

  None (edit)
Description Homayoun Shahri 2008-06-30 13:51:56 EDT
Description of problem:
The problem has to do with recovering from suspend. I initially had an issue
with RHEL5 in that at times it would not come out of suspend on a Dell c521
desktop (and when it did it would take more than 2 minutes!) and an IBM thinkpad
which case the following would be in the dmesg:

Uhhuh. NMI received for unknown reason b0 on CPU 0.
You probably have a hardware problem with your RAM chips
Dazed and confused, but trying to continue

This issue was fixed in kernel 2.6.18-53.x.x and all my machines would into 
suspend mode and come out of suspend mode gracefully. However, with RHEL5.2
(kernel 2.6.18-92.1.6.el5) I am facing the same old issue again. On my laptop 1
out of 3 times the machine locks up when coming out of suspend. No video,
initially keyboard functions, but shortly the keyboard freezes as well. I can
get a text mode terminal to investigate further (cntl-alt-f1, etc).

I wonder what was changed in this version of kernel?

Thanks,
Homayoun


Version-Release number of selected component (if applicable):

RHEL5.2 running 2.6.18-92.1.6.el5

How reproducible:
1 out of 3 times

Steps to Reproduce:
1. Suspend the machine
2. Try to resume
3.
  
Actual results:
No video, and eventually complete freeze.

Expected results:
Machine should resume gracefully.

Additional info:
dmesg:
Uhhuh. NMI received for unknown reason b0 on CPU 0.
You probably have a hardware problem with your RAM chips
Dazed and confused, but trying to continue
Comment 1 Matthew Garrett 2008-07-08 09:00:35 EDT
Just to clarify, do you see the NMI message with 2.6.18-92.1.6.el5 or just
2.6.18-53? Which wireless hardware is present in the Thinkpad?
Comment 2 Homayoun Shahri 2008-07-08 12:39:24 EDT
I get the NMI message with 2.6.18-92.1.6.el5, and not with 2.6.18-53.xx. I used
to get this message when I upgraded to RHEL5, but it went away with 2.6.18-53.xx
versions of kernel, only to come back again with the latest kernel, and RHEL5.2. 
Thinkpad has an Intel IPW3945. As far as I know this driver has not changed. In
fact I use the pre-built driver that I downloaded from RHN site, if this is of
any help.


Comment 3 Matthew Garrett 2008-07-10 08:53:26 EDT
Ok, thanks. It appears likely that one of your drivers is doing something
inappropriate in its resume path. Could you attach the output of the lsmod
command? Also, if it's possible to save a copy of the output of dmesg including
the NMI error, that would be helpful.
Comment 4 Homayoun Shahri 2008-07-10 13:31:57 EDT
Created attachment 311497 [details]
output of dmesg

Please note that I have not added/modified any drivers since RHEL 5.1
Comment 5 Homayoun Shahri 2008-07-10 13:33:50 EDT
output of /sbin/lsmod:
Module                  Size  Used by
arc4                    6209  2 
ieee80211_crypt_wep     9153  1 
cisco_ipsec           559900  0 
autofs4                24517  2 
hidp                   23105  2 
l2cap                  29505  5 hidp
bluetooth              53797  2 hidp,l2cap
vmnet                  49724  12 
vmblock                20512  3 
vmmon                 945108  0 
sunrpc                144893  1 
cpufreq_ondemand       12493  2 
vfat                   15809  1 
fat                    51165  1 vfat
dm_mirror              29252  0 
dm_multipath           22089  0 
dm_mod                 61661  2 dm_mirror,dm_multipath
video                  21193  0 
sbs                    18533  0 
ibm_acpi               33113  0 
backlight              10049  2 video,ibm_acpi
i2c_ec                  9025  1 sbs
button                 10705  0 
battery                13637  0 
asus_acpi              19289  0 
ac                      9157  0 
ipv6                  258273  26 
xfrm_nalgo             13765  1 ipv6
crypto_api             11969  1 xfrm_nalgo
parport_pc             29157  0 
lp                     15849  0 
parport                37513  2 parport_pc,lp
snd_hda_intel          24793  1 
snd_hda_codec         210881  1 snd_hda_intel
snd_seq_dummy           7877  0 
snd_seq_oss            32577  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                49585  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11725  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42945  0 
snd_mixer_oss          19009  1 snd_pcm_oss
joydev                 13313  0 
ata_piix               22341  0 
snd_pcm                72005  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer              24517  2 snd_seq,snd_pcm
ipw3945               176808  1 
snd                    52421  11
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
ide_cd                 40033  0 
sg                     36189  0 
soundcore              11553  1 snd
ieee80211              33289  1 ipw3945
serio_raw              10693  0 
pcspkr                  7105  0 
ieee80211_crypt        10049  2 ieee80211_crypt_wep,ieee80211
e1000e                 92801  0 
snd_page_alloc         14281  2 snd_hda_intel,snd_pcm
cdrom                  36705  1 ide_cd
airprime               12229  0 
i2c_i801               11597  0 
usbserial              33065  1 airprime
i2c_core               23745  2 i2c_ec,i2c_i801
ahci                   30149  5 
libata                143997  2 ata_piix,ahci
sd_mod                 24897  6 
scsi_mod              134605  3 sg,libata,sd_mod
ext3                  123593  3 
jbd                    56553  1 ext3
uhci_hcd               25421  0 
ohci_hcd               23261  0 
ehci_hcd               33357  0 

Comment 6 Matthew Garrett 2008-07-16 09:37:42 EDT
Can you reproduce this running a Red Hat kernel rather than a CentOS one?
Comment 7 Homayoun Shahri 2008-07-16 12:40:48 EDT
I have recently switched to CentOS (as of RHEL5.1), but this issue is not unique
to CentOS, and I have had this same issue with RHEL5.0. I will try Redhat
version of the same kernel shortly.

Comment 8 Homayoun Shahri 2009-02-10 17:02:26 EST
The issue that I was reporting is now resolved at least as of 2.6.18-92.1.22.el5, but perhaps earlier. This issue might been related to ATI graphics driver, or a bad DDR module that I had, but I no experience any kernel panic or hang up.
Comment 9 Matthew Garrett 2009-03-04 06:12:56 EST
Ok, I'm marking this as fixed.

Note You need to log in before you can comment on or make changes to this bug.