Bug 453471 - kernel update causes sound to play too fast
kernel update causes sound to play too fast
Status: CLOSED DUPLICATE of bug 441087
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 16:29 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 10:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2008-06-30 16:29:43 EDT
Description of problem:

Sometime recently I "yum update"d my F8 box.  After this update,
all songs sound like they are sung by the chipmunks -- the playback
is too fast.

After some debugging on #pulseaudio we concluded that this is an alsa
problem.  (I disabled pulseaudio and used mplayer's alsa back end to
verify the problem remained.)


Version-Release number of selected component (if applicable):

opsy. uname -a
Linux opsy 2.6.25.6-27.fc8 #1 SMP Fri Jun 13 16:38:52 EDT 2008 i686 i686 i386
GNU/Linux

/proc/asound/cards says:

opsy. cat /proc/asound/cards
 0 [I82801BAICH2   ]: ICH - Intel 82801BA-ICH2
                      Intel 82801BA-ICH2 with AD1885 at irq 17

opsy. grep 'front DAC' /proc/asound/card0/codec97#0/ac97#0-0
PCM front DAC    : 48000Hz

Also, saw this in /var/log/messages:

Jun 29 08:58:03 opsy kernel: intel8x0_measure_ac97_clock: measured 50944 usecs
Jun 29 08:58:03 opsy kernel: intel8x0: measured clock 78 rejected
Jun 29 08:58:03 opsy kernel: intel8x0: clocking to 48000


This looks vaguely like this alsa bug report:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=69
Comment 1 Martin Burchell 2008-07-04 19:02:13 EDT
Same problem for me after updating to kernel-2.6.25.9-40.fc8

Adding this line to /etc/modprobe.conf fixed it for me:
options snd-intel8x0 ac97_clock=48000

See also
https://bugzilla.redhat.com/show_bug.cgi?id=441087
Comment 2 Tom Tromey 2008-07-10 10:36:26 EDT

*** This bug has been marked as a duplicate of 441087 ***

Note You need to log in before you can comment on or make changes to this bug.