Bug 453481 - [openjdk] OOo writer crashes when using wizards
[openjdk] OOo writer crashes when using wizards
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
9
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 18:19 EDT by Ian Chapman
Modified: 2008-11-06 09:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 09:44:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace of crash from OO writer (10.64 KB, text/plain)
2008-06-30 18:19 EDT, Ian Chapman
no flags Details
Java error log related to oo crash. (91.19 KB, text/plain)
2008-06-30 18:25 EDT, Ian Chapman
no flags Details
mapped stack (12.51 KB, text/plain)
2008-07-01 09:12 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Ian Chapman 2008-06-30 18:19:36 EDT
Description of problem:

OO writer crashes when a wizard eg the Letter wizard is used.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.4.1-17.4.fc9.ppc
java-1.6.0-openjdk-1.6.0.0-0.15.b09.fc9.ppc

How reproducible:


Steps to Reproduce:
1. Run open office writer
2. Select File -> Wizards -> Letter
3.
  
Actual results:

Instantly crashes

Expected results:

Should open the letter wizard

Additional info:
Comment 1 Ian Chapman 2008-06-30 18:19:36 EDT
Created attachment 310623 [details]
Trace of crash from OO writer
Comment 2 Ian Chapman 2008-06-30 18:25:42 EDT
Created attachment 310625 [details]
Java error log related to oo crash.
Comment 3 Caolan McNamara 2008-07-01 08:34:30 EDT
I wonder if this also happens if you use libgcj ? 

Assuming that both are installed, you can tell OOo to use the other with
tools->options->openoffice.org->java and select the "Free Software Foundation"
option instead of the auto-selected "Sun Microsystems" option. And then restart
OOo and try the wizards again
Comment 4 Caolan McNamara 2008-07-01 09:12:11 EDT
Created attachment 310663 [details]
mapped stack
Comment 5 Caolan McNamara 2008-07-01 09:17:13 EDT
report_should_not_reach_here(char const*, int) ... os_abort inside openjdk

Not sure if this is openjdk specific, but I'm fairly sure that it worked under
libgcj the last time I was able to check under ppc. #3 shows how to try with
libgcj to see if that theory is correct
Comment 6 Ian Chapman 2008-07-01 10:35:19 EDT
(In reply to comment #3)
> I wonder if this also happens if you use libgcj ? 

Yes unfortunately it does. Well the behaviour is slightly different. Instead of
an absolute crash, OO locks solid and CPU usage hangs around %100 indefinately
in some kind of infinite loop.

This is with: libgcj-4.3.0-8.ppc

If there's any way I can get useful debugging information from this, let me know.
Comment 7 Ian Chapman 2008-07-01 22:08:07 EDT
Out of curiosity I've just tried IBM's java implementation for PPC:

ibm-java-ppc-sdk-6.0-1.0.ppc.rpm (Java 1.6.0)

and surprisingly this works perfectly. Obviously not an official solution however.
Comment 8 Lillian Angel 2008-11-05 13:19:56 EST
Can you try to reproduce this with the latest version of OpenJDK in rawhide?
Comment 9 Gary Benson 2008-11-06 03:34:31 EST
This was probably http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=184.
It should be fixed now, at least upstream.

Note You need to log in before you can comment on or make changes to this bug.