Bug 453547 - [NetApp 4.8 bug] Specifying rr_min_io in device specific section of multipath.conf fails during multipath configuration.
[NetApp 4.8 bug] Specifying rr_min_io in device specific section of multipath...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.7
All Linux
high Severity medium
: rc
: 4.8
Assigned To: Ben Marzinski
Corey Marthaler
: OtherQA
Depends On:
Blocks: 450897 458123
  Show dependency treegraph
 
Reported: 2008-07-01 05:31 EDT by Rajashekhar M A
Modified: 2010-01-11 21:32 EST (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* multipath did not process the rr_min_io variable in the multipath.conf file. Regardless of what value rr_min_io was set to, multipath would perform 1000 I/Os before switching ports. Multipath now processes rr_min_io correctly and honors the setting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajashekhar M A 2008-07-01 05:31:00 EDT
Description of problem:

Specifying the option rr_min_io in the NETAPP device specific section in RHEL
4.7 Snapshot 4 has no effect while configuring the maps. I see that the value
for each map is getting set to default (1000) instead of the value that is
specified in the multipath.conf file:

# dmsetup table
VolGroup00-LogVol01: 0 8192000 linear 8:2 133366144
mpath267: 0 20971520 multipath 1 queue_if_no_path 0 2 1 round-robin 0 2 1 8:16
1000 8:64 1000 round-robin 0 2 1 8:32 1000 8:48 1000
VolGroup00-LogVol00: 0 133365760 linear 8:2 384


Version-Release number of selected component (if applicable):

# rpm -qa | grep device
device-mapper-multipath-0.4.5-31.el4
device-mapper-1.02.25-2.el4
device-mapper-1.02.25-2.el4


How reproducible:

Always

Steps to Reproduce:

1. Add the rr_min_io option in device specific section in multipath.conf -

devices {
        device {
                vendor                        "NETAPP"
                product                       "LUN"
                getuid_callout                "/sbin/scsi_id -g -u -s /block/%n"
                flush_on_last_del             yes
                prio_callout                  "/sbin/mpath_prio_netapp /dev/%n"
                features                      "1 queue_if_no_path"
                hardware_handler              "0"
                path_grouping_policy          group_by_prio
                failback                      immediate
                rr_min_io                     128
                rr_weight                     uniform
                path_checker                  directio
        }
}

2. Reconfigure the maps by running "multipath -F" and then by running "multipath
-v3"

Actual results:

The maps get configured with default value for rr_min_io (1000) instead of the
specified value in multipath.conf.

# dmsetup table
VolGroup00-LogVol01: 0 8192000 linear 8:2 133366144
mpath267: 0 20971520 multipath 1 queue_if_no_path 0 2 1 round-robin 0 2 1 8:16
1000 8:64 1000 round-robin 0 2 1 8:32 1000 8:48 1000
VolGroup00-LogVol00: 0 133365760 linear 8:2 384


Expected results:

The rr_min_io should have been configured with the value specified in
multipath.conf file.

Additional info:

1. This option when specified in the "defaults" section instead of the device
section, it works fine. The maps get configured with the specified value.

defaults {
        user_friendly_names yes
        rr_min_io 128
}

# dmsetup table
VolGroup00-LogVol01: 0 8192000 linear 8:2 133366144
mpath267: 0 20971520 multipath 1 queue_if_no_path 0 2 1 round-robin 0 2 1 8:64
128 8:16 128 round-robin 0 2 1 8:32 128 8:48 128
VolGroup00-LogVol00: 0 133365760 linear 8:2 384


2. This bug is not seen in RHEL 5.2 i.e. the value gets configured properly when
the option is specified in device specific section.
Comment 1 Andrius Benokraitis 2008-07-01 09:28:13 EDT
I would assume this worked properly in 4.6, but no longer in 4.7 Snapshot 4?
Comment 2 Rajashekhar M A 2008-07-01 10:01:46 EDT
No. This bug exists in RHEL 4.6 too.
Comment 3 Andrius Benokraitis 2008-07-01 10:10:11 EDT
OK - since this isn't debilitating, and there is a work around, we'll have to
push this to 4.8.
Comment 4 RHEL Product and Program Management 2008-09-05 13:24:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Ben Marzinski 2009-01-16 16:53:39 EST
Multipath wasn't correctly processing the rr_min_io option in multipath.conf. So it would only work for the compiled in defaults. Fixed.
Comment 9 Ruediger Landmann 2009-02-02 00:50:31 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* multipath did not process the rr_min_io variable in the multipath.conf file. Regardless of what value rr_min_io was set to, multipath would perform 1000 I/Os before switching ports. Multipath now processes rr_min_io correctly and honors the setting.
Comment 10 Chris Ward 2009-02-20 08:31:31 EST
~~ Attention Partners!  ~~
RHEL 4.8 Partner Alpha has been released on partners.redhat.com. There should
be a fix present in the Beta, which addresses this bug. If you have already completed testing your other URGENT priority bugs, and you still haven't had a chance yet to test this bug, please do so at your earliest convenience, to ensure that only the highest possible quality bits are shipped in the upcoming public Beta drop.

If you encounter any issues, please set the bug back to the ASSIGNED state and
describe the issues you encountered. Further questions can be directed to your
Red Hat Partner Manager.

Thanks, more information about Beta testing to come.
 - Red Hat QE Partner Management
Comment 11 Naveen Reddy 2009-02-25 04:48:39 EST
I have verified in RHEL4.8 and this issue is resolved.
Comment 13 errata-xmlrpc 2009-05-18 16:31:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1011.html

Note You need to log in before you can comment on or make changes to this bug.