Bug 453699 - kernel BUG at lib/list_debug.c:72! when running rsync test suite on reiserfs
kernel BUG at lib/list_debug.c:72! when running rsync test suite on reiserfs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 00:06 EDT by Matt McCutchen
Modified: 2009-06-09 21:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 21:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (2.82 KB, text/plain)
2008-07-02 00:07 EDT, Matt McCutchen
no flags Details

  None (edit)
Description Matt McCutchen 2008-07-02 00:06:07 EDT
Description of problem:
The kernel encounters a "BUG" when I run the rsync 3.0.3 test suite ("make
test") on a reiserfs filesystem.  The filesystem is on an LVM logical volume
whose physical volume is LUKS-encrypted.  The fstab line looks like:

/dev/mapper/vg-root    /    reiserfs    rw,noatime,acl    0 1

Version-Release number of selected component (if applicable):
kernel-2.6.25.6-55.fc9.i686

How reproducible:
Every time for me.

Steps to Reproduce:
git clone git://git.samba.org/rsync.git
cd rsync && ./configure && make test

Actual results:
The kernel hits a BUG (I will attach the stack trace) and the test suite freezes.

Expected results:
The test suite completes.

Additional info:
Comment 1 Matt McCutchen 2008-07-02 00:07:19 EDT
Created attachment 310756 [details]
dmesg output
Comment 2 Matt McCutchen 2008-07-02 13:04:12 EDT
The same problem occurs with kernel-2.6.26-0.104.rc8.git2.fc10.i686, but the
computer freezes too soon for me to obtain dmesg output.
Comment 3 Eric Sandeen 2008-07-03 16:57:25 EDT
You may have better luck reporting this on the kernel.org bugzilla, or on the
reiser or kernel mailing lists.  It's unlikely that it is unique to fedora
(which would also be worth a test, though)

Thanks,
-Eric
Comment 4 Matt McCutchen 2008-07-03 22:31:50 EDT
OK, I will investigate some more and report this "upstream".

kernel-2.6.24.7-92.fc8.i686 does not seem to have the problem: I ran the rsync
testsuite 120 times without incident.  I will use that kernel until the problem
is resolved.
Comment 5 Eric Sandeen 2008-07-03 22:36:39 EDT
I suspect that that released kernel simply did not have the list debugging in
place; check CONFIG_DEBUG_LIST in /boot/config*

-Eric
Comment 6 Matt McCutchen 2008-07-03 23:47:13 EDT
That setting is enabled:

$ grep CONFIG_DEBUG_LIST /boot/config-2.6.24.7-92.fc8 
CONFIG_DEBUG_LIST=y
Comment 7 Eric Sandeen 2008-07-04 00:04:54 EDT
Hm, interesting.  I don't see anything offhand in the reiserfs git logs that
looks related.

If you're highly motivated, since you have a testcase you can trigger it with,
you could try a git bisect between 2.6.24 and 2.6.25, using the fedora kernel
configs.

If you started with restricting the bisect to changes in fs/reiserfs it would
probably go very quickly (if the problem is indeed a change under fs/reiserfs,
but that seems fairly likely from a quick look at the oops)

Comment 8 Matt McCutchen 2008-07-05 21:38:34 EDT
Bisection points to 3227e14c3cab5ef7972c72eb13c13de444b5bfbc as the faulty
commit.  I will test whether reverting that commit in the current vanilla kernel
fixes the problem and then report to the reiserfs-devel list.
Comment 9 Eric Sandeen 2008-07-05 21:41:58 EDT
cool, nice job finding it.  sorry for making you do all the work ;)
Comment 10 Eric Sandeen 2008-07-05 23:38:19 EDT
I'm going to close this as an UPSTREAM problem but if you get a resolution from
the reiserfs folks, please ping me via this bug and I'll be happy to put it into
a fedora kernel update.

Thanks!

-Eric
Comment 11 Matt McCutchen 2008-07-08 15:24:12 EDT
Cases like this make me think "UPSTREAM" should be a status rather than a
resolution.

I finally put together the upstream report:

http://marc.info/?l=reiserfs-devel&m=121554473726081&w=2

I will comment again if a resolution is reached.
Comment 12 Eric Sandeen 2008-07-08 15:31:41 EDT
re, upstream as status, yup, maybe so.  I'm not terribly happy to close as
UPSTREAM but the reality is that for some things, taking the bug to upstream
will probably be the faster path to resolution.  And when there's a
willing/savvy bug reporter who can do so ... :)

-Eric
Comment 13 Matt McCutchen 2008-07-08 17:00:24 EDT
Jeff Mahoney has a patch that fixes the bug for me:

http://marc.info/?l=reiserfs-devel&m=121554230221773&w=2
Comment 14 Eric Sandeen 2008-07-08 17:49:57 EDT
Committed to rawhide & F-9 kernels, thanks!

-Eric
Comment 15 Matt McCutchen 2008-07-09 09:45:53 EDT
The patch is now in the vanilla kernel as commit eb35c218.
Comment 16 Fedora Update System 2008-07-21 09:56:55 EDT
kernel-2.6.25.11-97.fc9 has been submitted as an update for Fedora 9
Comment 17 Fedora Update System 2008-07-23 03:17:22 EDT
kernel-2.6.25.11-97.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6634
Comment 18 Matt McCutchen 2009-01-08 21:57:50 EST
AFAIK, this has been fixed for a long time.  Is there any further QA to be done, or shall I close the bug?
Comment 19 Bug Zapper 2009-06-09 21:52:45 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Eric Sandeen 2009-06-09 21:59:57 EDT
Auto-bug-closers missed this one after updates pushed, I guess.

Note You need to log in before you can comment on or make changes to this bug.