Bug 453755 - unregister_netdevice: waiting for vlan10 to become free. Usage count = 1
unregister_netdevice: waiting for vlan10 to become free. Usage count = 1
Status: CLOSED DUPLICATE of bug 450855
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 08:05 EDT by Juanjo Villaplana
Modified: 2009-06-03 06:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 06:45:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network config (875 bytes, application/x-gzip)
2008-07-02 08:05 EDT, Juanjo Villaplana
no flags Details

  None (edit)
Description Juanjo Villaplana 2008-07-02 08:05:15 EDT
Description of problem:

Can't stop network. When running "service network stop" the following error
appears on syslog and the network doesn't stop:

unregister_netdevice: waiting for vlan10 to become free. Usage count = 1

We are using vlans on top of bonding interfaces.

Version-Release number of selected component (if applicable):

kernel-2.6.18-92.el5 and kernel-2.6.18-92.1.6.el5

Works fine with kernel-2.6.18-53.1.21.el5

How reproducible:

Almost always

Steps to Reproduce:

1. service network stop
  
Actual results:

Network doesn't stop and can't kill "service network stop"

Expected results:

Network interfaces should be stopped

Additional info:

May be a duplicate of Bug 423791 ?
Comment 1 Juanjo Villaplana 2008-07-02 08:05:15 EDT
Created attachment 310782 [details]
Network config
Comment 2 Juanjo Villaplana 2008-07-02 08:35:55 EDT
When disabling IPv6 kernel-2.6.18-92.1.6.el5 also works fine:

    - Add the follwing entries to /etc/modprobe.conf:

      alias net-pf-10 off
      alias ipv6 off

    - chkconfig ip6tables off
Comment 3 Neil Horman 2009-04-07 16:05:36 EDT
can you try the 5.3 kernel (kernel-2.6.9-128.el5)?

I think this might be a dup of bz450855.  That was fixed in -99, correcting an unbalanced reference count which, if leaked, could result in this behavior
Comment 4 Neil Horman 2009-04-16 06:49:03 EDT
ping?  Any results on 5.3 testing?
Comment 5 Juanjo Villaplana 2009-04-20 08:26:20 EDT
I will try to test kernel-2.6.9-128.el5 this week ...
Comment 6 Neil Horman 2009-04-20 09:49:10 EDT
Ok, please report results as soon as you have them.  Thank you!
Comment 7 Neil Horman 2009-05-18 10:25:40 EDT
ping, any update?
Comment 8 Juanjo Villaplana 2009-06-03 04:35:42 EDT
Tested with kernel 2.6.18-128.1.6.el5:

1. Removed net-pf-10 and ipv6 entries from /etc/modprobe.conf
2. Started ip6tables
3. Issued several 'service network restart' and all worked fine
4. Restarted the server.
5. Issued several 'service network restart' and all worked fine

The issue seems to be solved. Thanks!
Comment 9 Neil Horman 2009-06-03 06:45:14 EDT
k, thank you!

*** This bug has been marked as a duplicate of bug 450855 ***

Note You need to log in before you can comment on or make changes to this bug.