Bug 453810 - yum improper calculates percentage of overall work progress (more than 100%)
yum improper calculates percentage of overall work progress (more than 100%)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 13:49 EDT by JanS
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version: python-urlgrabber-0:3.0.0-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 14:57:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum screenshot with more than 100 percent overall progress (147.76 KB, image/png)
2008-07-02 13:49 EDT, JanS
no flags Details
same bug with newest python-urlgrabber 3.0.0-8.fc9 (218.11 KB, image/png)
2008-07-02 15:52 EDT, JanS
no flags Details
yum output, last comunicate during download was (118%) (3.65 KB, text/plain)
2008-07-03 10:10 EDT, JanS
no flags Details
screenshot during yum process from log given above (173.41 KB, image/png)
2008-07-03 10:12 EDT, JanS
no flags Details

  None (edit)
Description JanS 2008-07-02 13:49:15 EDT
Description of problem:
While downloading rpm's yum displays download progress for file and overall
downloads progress as percentage information.
After something goes wrong (loss of network for a while), yum resumes
downloading from another mirror. After this percentage overall progress is not
well calculated. This could lead to value over 100% (as on attached screenshot)


Version-Release number of selected component (if applicable):
yum 3.2.16-2.fc9
Fedora 9, 2.6.25.6-55.fc9.x86_64

How reproducible:
It is easy to reproduce.
Try to update few bigger packeges and unplug ethernet in the middle of
downloading process for a while (not too long not too short, few seconds to
force yum to try another mirror) or disable wireless and plug ethernet after a
while.

Steps to Reproduce:
1. while yum is downloading rpm's, unplug your ethernet cable 
2. after a while plug in, to force yum to try another mirror but continue to
download
3. watch overall progress percentage (in brackets)
4. at the end you should see 101%, 102%, 103%, etc
  
Actual results:
98%, 99%, 100%, 101%, 102%, 103%, 104%, etc...

Expected results:
98%, 99%, 100%. Finished

Additional info:
see attachment
Comment 1 JanS 2008-07-02 13:49:15 EDT
Created attachment 310834 [details]
yum screenshot with more than 100 percent overall progress
Comment 2 James Antill 2008-07-02 14:57:43 EDT
 If you upgrade to the latest python-urlgrabber this should go away almost all
the time (incl. the case in the screenshot). Although for all corner cases you
need yum-3.2.17, when that comes out.
Comment 3 JanS 2008-07-02 15:52:08 EDT
Created attachment 310848 [details]
same bug with newest python-urlgrabber 3.0.0-8.fc9

I have allready uptodate python-urlgrabber.
And was able to reproduce ths bug once more (see attachment).
Comment 4 James Antill 2008-07-02 19:11:18 EDT
 Can you show the top part of that output ... as I said there are certain
conditions where urlgrabber can't fix it itself, for instance if the remote end
doesn't give urlgrabber the full size ... or if it all gets downloaded but then
doesn't checksum.
 Does it sound like any of that could have happened to you?
Comment 5 JanS 2008-07-03 10:10:06 EDT
Created attachment 310923 [details]
yum output, last comunicate during download was (118%)

see next attachement, screenshot from same situation as log, but caught in
action 104%.

I dont think that it is because of wrong full size got from internet, rather
from interrupiton. One can check sizes of this updates and compare with the
log.

Maybe its because of one of my yum extensions?

yum.noarch				 3.2.16-2.fc9		installed
yum-allowdowngrade.noarch		 1.1.14-4.fc9		installed
yum-fastestmirror.noarch		 1.1.14-4.fc9		installed
yum-metadata-parser.x86_64		 1.1.2-8.fc9		installed
yum-packagekit.x86_64			 0.1.12-13.20080522.fc9 installed
yum-presto.noarch			 0.4.5-1.fc9		installed
yum-utils.noarch			 1.1.14-4.fc9		installed
python-urlgrabber.noarch		 3.0.0-8.fc9		installed
Comment 6 JanS 2008-07-03 10:12:38 EDT
Created attachment 310925 [details]
screenshot during yum process from log given above
Comment 7 James Antill 2008-07-03 11:19:58 EDT
 Ok, after being very confused for a bit, I see the problem.
 This was actually fixed in
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-5396 which is still in
updates-testing ... sorry. I thought I'd already moved it to updates, so just
took the version from there.

 I'll move it to updates now.

Note You need to log in before you can comment on or make changes to this bug.