Bug 453864 - Latest kernel/wireless updates breaks WPA(-PSK?)
Latest kernel/wireless updates breaks WPA(-PSK?)
Status: CLOSED DUPLICATE of bug 453390
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 18:34 EDT by Stefan Becker
Modified: 2008-07-03 10:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 10:02:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wpa_supplicant debugging logfile from kernel-2.6.25.9-72.fc9.i686 (OK) (13.89 KB, text/plain)
2008-07-02 18:36 EDT, Stefan Becker
no flags Details
wpa_supplicant debugging logfile from kernel-2.6.25.9-76.i686 (BROKEN) (11.67 KB, text/plain)
2008-07-02 18:40 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2008-07-02 18:34:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
With the following kernels I can connect without problems using either the Intel 3945 in the laptop or an Atheros-based PCMCIA card:

 kernel-2.6.25.6-55.fc9.i686  (officially released)
 kernel-2.6.25.9-72.fc9.i686  (last internal kernel on koji before wireless updates)


Version-Release number of selected component (if applicable):
kernel-2.6.25.9-76.fc9.i686

How reproducible:
Always


Steps to Reproduce:
1. boot into 2.6.25.9-76.fc9
2. login

Actual Results:
See NetworkManager trying to connect (LED blinks) but never completes the connection until timeout.

Expected Results:
NetworkManager can create WLAN WPA connection

Additional info:
I tried by hand with

  # service NetworkManager stop
  # wpa_supplicant -i wlan0 -c wpa_supplicant.conf -dd

I'll attach the OK/error log files.
Comment 1 Stefan Becker 2008-07-02 18:36:16 EDT
Created attachment 310863 [details]
wpa_supplicant debugging logfile from kernel-2.6.25.9-72.fc9.i686 (OK)
Comment 2 Stefan Becker 2008-07-02 18:40:18 EDT
Created attachment 310865 [details]
wpa_supplicant debugging logfile from kernel-2.6.25.9-76.i686 (BROKEN)

When you compare the OK to the BROKEN log file you see that everything works up
to here:

State: 4WAY_HANDSHAKE -> GROUP_HANDSHAKE

In the error case it never seems to receive the group ACK from the base
station.
Comment 3 Stefan Becker 2008-07-02 18:41:50 EDT
I also  tried the latest kernel on Koji

 kernel-2.6.25.9-79.fc9.i686

which has even more wireless updates from upstream: still broken :-(
Comment 4 William Lovaton 2008-07-02 22:22:29 EDT
Yeah, me too  =(

Booting 2.6.25.9-76 I can't connect to my wireless network.  Booting back with
2.6.25.6-55 works fine as expected.

I am using an iwl3945 NIC.

Connecting to not protected networks works fine with both kernels, the problem
seems to be with the ones that are protected.
Comment 5 Ryan Farmer 2008-07-02 23:19:48 EDT
I think this may be the same bug as #453882 which I posted earlier.

Note that WEP still works, so if you live in an area where you doubt your in
range of anyone who knows how to crack WEP, you could use that, and then disable
remote management of your router along with MAC address filters as a workaround
until a new version of wpa supplicant is here.
Comment 6 Stefan Becker 2008-07-03 01:47:00 EDT
Latest kernel from koji

  kernel-2.6.25.9-81.fc9.i686

is still broken.

I also installed the only kernel between -72 (OK) and -76 (broken) from koji

  kernel-2.6.25.9-74.fc9.i686

It is also broken. That limits the culprit down to

<http://marc.info/?l=linux-netdev&m=121346686508160&w=2>  (-73)

or

<http://marc.info/?l=linux-wireless&m=121440912502527&w=2> (-74)

Looking at the changes I would put my money on one of those from -73:

Harvey Harrison (11):
      mac80211: add helpers for frame control testing
      mac80211: remove ieee80211_get_morefrag
      mac80211: make ieee80211_get_hdrlen_from_skb return unsigned
      mac80211: add utility function to get header length
      mac80211: wpa.c use new access helpers
      mac80211: use new helpers in util.c - ieee80211_get_bssid()
      mac80211: wme.c use new helpers
      mac80211: rx.c use new helpers
      mac80211: tkip.c consolidate tkip IV writing in helper
      mac80211: tkip.c fold ieee80211_gen_rc4key into its one caller
      mac80211: tkip.c use a local struct tkip_ctx in ieee80211_get_tkip_key
Comment 7 John W. Linville 2008-07-03 10:02:00 EDT

*** This bug has been marked as a duplicate of 453390 ***

Note You need to log in before you can comment on or make changes to this bug.