Bug 453871 - RFE: Update synaptics to 20080702git and include MultiFingerButton patch
RFE: Update synaptics to 20080702git and include MultiFingerButton patch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 19:23 EDT by Stewart Adam
Modified: 2008-09-24 00:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.15.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 00:58:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "cvs diff -u" on F-9 branch (10.25 KB, patch)
2008-07-02 19:23 EDT, Stewart Adam
no flags Details | Diff

  None (edit)
Description Stewart Adam 2008-07-02 19:23:32 EDT
The attached file updates synaptics to today's git, update the existing patches
accordingly as well as adds a new patch to support "MultiFingerButton".

It would be great to have this commited since the git checkout improves the
double-finger scroll detection. The MultiFingerButton allows users to configure
alternate button events when clicking with two fingers present on the touchpad.
Comment 1 Stewart Adam 2008-07-02 19:23:32 EDT
Created attachment 310868 [details]
Output of "cvs diff -u" on F-9 branch
Comment 2 Peter Hutterer 2008-08-22 02:43:24 EDT
Stewart:
The cvs diff is missing the patch you added. Nevertheless, I believe the following commit may be equivalent to what you wanted to add?

http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/commit/?id=c32b4d47b94c2c18fab7f30588ddae8827e38f27

If so, it is part of xorg-x11-drv-synaptics, which superseeds synaptics.
Comment 3 Stewart Adam 2008-08-22 17:30:20 EDT
@missing patch, sorry about that, I don't use CVS very often ;)

That looks more or less what MultiFingerButton, essentially as long as it supports double-tap/clicking while two fingers are pressed --> right click I'm happy.
Comment 4 Peter Hutterer 2008-09-24 00:58:10 EDT
Closing, the TapButton or alternatively ClickFinger options provide that functionality.

Available from xorg-x11-drv-synaptics-0.15.0-2.f9.

Note You need to log in before you can comment on or make changes to this bug.