Bug 453872 - b43 not working with latest kernel 2.6.25.9-76
b43 not working with latest kernel 2.6.25.9-76
Status: CLOSED DUPLICATE of bug 453390
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 19:24 EDT by Nicolae Ghimbovschi
Modified: 2008-07-03 09:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 09:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The listing of the NetworkManager messages from /var/log/messages (15.79 KB, text/plain)
2008-07-02 19:24 EDT, Nicolae Ghimbovschi
no flags Details
Clip of network related log entries from /var/log/messages (34.07 KB, text/plain)
2008-07-02 20:36 EDT, Ryan Farmer
no flags Details

  None (edit)
Description Nicolae Ghimbovschi 2008-07-02 19:24:31 EDT
Description of problem:

After the latest kernel update I can't connect to my wireless AP using the 
Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
(rev 02)

The previous kernel is ok (2.6.25.6-55).
The Centrino Wireless ipw2100 works in both cases.

Version-Release number of selected component (if applicable):

kernel - 2.6.25.9-76
NetworkManager - 0.9.4.svn3675.fc9 

How reproducible:


Connect to the AP using Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g
Wireless LAN Controller and kernel 2.6.25.9-76
  

Actual results:

   Connecting failed

Expected results:

   Connecting 

Additional info:

See the attached file
Comment 1 Nicolae Ghimbovschi 2008-07-02 19:24:31 EDT
Created attachment 310869 [details]
The listing of the NetworkManager messages from /var/log/messages
Comment 2 Ryan Farmer 2008-07-02 20:34:59 EDT
I can confirm this on x86 AND x86-64 with same kernel, network manager, and wifi
chipset as reporter.

Will attach my network logs.
Comment 3 Ryan Farmer 2008-07-02 20:36:44 EDT
Created attachment 310870 [details]
Clip of network related log entries from /var/log/messages
Comment 4 Ryan Farmer 2008-07-02 20:45:55 EDT
I'm an idiot, this does not appear to be a b43 driver issue at all, can someone
mark this bug invalid?

It looks like a WPA Supplicant issue because connecting with WEP Passphrase
128-bit works just fine, as does no wifi security at all.

I'll refile this somewhere else, stay tuned.
Comment 5 John W. Linville 2008-07-03 09:58:18 EDT

*** This bug has been marked as a duplicate of 453390 ***

Note You need to log in before you can comment on or make changes to this bug.