Bug 4540 - Font Server locking during startup
Font Server locking during startup
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-08-15 19:44 EDT by klw
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-18 17:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description klw 1999-08-15 19:44:32 EDT
I have recently installed a new RH6.0 from a cd onto my
system. I applied all of the Red Hat Linux 6.0 General
Errata including the kernel upgrade to 2.2.5-22.  I also
upgraded to XFree86 3.3.4 to support my i740 based video
card. Everything was working fine.  Then i followed the
instructions from
to upgrade my kernel to the latest 2.2.11 after following
that process during bootup with the new kernel the font
server hung. I tried booting back in with my 2.2.5-22 kernel
still hung on the font server  I had to reboot in single
user mode and disable it in rc3.d, after that everything was
fine with the new kernel.  I tried re-running Xconfigurator
and re-intalling XFree86 3.3.4.  It still hangs if i enable
the font server. What is going on? And how do i fix it?
Comment 1 Preston Brown 1999-08-18 17:22:59 EDT
When you installed XFree86 3.3.4 you overwrote our own xfs, which is
specially modified.  You'll need to grab the xfs from our own packages
to have it work correctly with our /etc/rc.d/init.d/xfs startup
script, or manually put xfs into the background (&) in that script by
editing it -- we modified xfs to be a daemon, and the standard xfs is
simply a program.

Note You need to log in before you can comment on or make changes to this bug.