This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 454028 - Mass storage USB fails for some devices after kernel upgrade
Mass storage USB fails for some devices after kernel upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-03 17:35 EDT by Matthew Truch
Modified: 2008-09-13 21:26 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.25.11-97.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-13 21:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Truch 2008-07-03 17:35:43 EDT
Description of problem:
After recently upgrading my kernel to the most recent (via yum,
kernel-2.6.25.9-76.fc9.i686), My Nikon D40 (set in USB Mass Storage mode) no
longer works when connected to my F9 laptop.  It has worked on countless
occasions previously.  I have tested the camera/SD card combo on another machine
(a desktop with [old] FC6) as well as other SD cards in the camera and they do
not work on the F9 machine, but always work on the FC6 machine.  My USB key,
however, does still work on the F9 laptop.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Plug in Mass Storage Camera
  
Actual results:
Nothing happens except for many errors in /var/log/messages

Expected results:
Popup appears giving option to mount the newly plugged in USB device.

Additional info:
Pertinent part of /var/log/messages below:
Jul  3 17:27:11 tbc kernel: usb 1-4: new high speed USB device using ehci_hcd
and address 7
Jul  3 17:27:11 tbc kernel: usb 1-4: configuration #1 chosen from 1 choice
Jul  3 17:27:11 tbc kernel: scsi6 : SCSI emulation for USB Mass Storage devices
Jul  3 17:27:11 tbc kernel: usb 1-4: New USB device found, idVendor=04b0,
idProduct=0413
Jul  3 17:27:11 tbc kernel: usb 1-4: New USB device strings: Mfr=1, Product=2,
SerialNumber=3
Jul  3 17:27:11 tbc kernel: usb 1-4: Product: NIKON DSC D40
Jul  3 17:27:11 tbc kernel: usb 1-4: Manufacturer: NIKON
Jul  3 17:27:11 tbc kernel: usb 1-4: SerialNumber: 3058394
Jul  3 17:27:16 tbc kernel: scsi 6:0:0:0: Direct-Access     NIKON    D40       
      1.11 PQ: 0 ANSI: 2
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] 2816174081 512-byte hardware
sectors (1441881 MB)
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] Write Protect is off
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] 2816174081 512-byte hardware
sectors (1441881 MB)
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] Write Protect is off
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
Jul  3 17:27:16 tbc kernel:  sdb: sdb1
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: [sdb] Attached SCSI removable disk
Jul  3 17:27:16 tbc kernel: sd 6:0:0:0: Attached scsi generic sg2 type 0
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816173952
Jul  3 17:27:17 tbc kernel: printk: 327 messages suppressed.
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173952
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816173953
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173953
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173954
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173955
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173956
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173957
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173958
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173959
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816173952
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173952
Jul  3 17:27:17 tbc kernel: Buffer I/O error on device sdb, logical block 2816173953
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174064
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174065
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174064
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174065
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174072
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174073
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174072
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174073
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174016
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174017
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174064
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK
driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Sense Key : Medium Error [current]
Jul  3 17:27:17 tbc kernel: sd 6:0:0:0: [sdb] Add. Sense: Unrecovered read error
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174065
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 2816174080
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 32
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 33
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 64
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 64
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 64
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 64
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:17 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:20 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:20 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:20 tbc kernel: end_request: I/O error, dev sdb, sector 1
Jul  3 17:27:20 tbc kernel: end_request: I/O error, dev sdb, sector 0
Jul  3 17:27:20 tbc kernel: end_request: I/O error, dev sdb, sector 1
Comment 1 Dave Jones 2008-07-03 17:46:55 EDT
I think this just needs a quirk added. There's a bunch of entries for the D40 in
the kernel already, but only up to firmware 1.10.  I just added a patch adding
an entry for 1.11.

It'll be in builds versioned 2.6.25.10-83.fc9 and higher.
Let us know if that fixes it? 
Comment 2 Matthew Truch 2008-07-03 17:58:01 EDT
Awesome.  Any ETA for builds at 2.6.25.10-83.fc9 and higher, or should I just
check koji periodically?
Comment 3 Dave Jones 2008-07-03 18:06:13 EDT
Chuck is going to kick off a build this evening, so yeah, watch out for it in koji.
Comment 4 Matthew Truch 2008-07-04 12:02:59 EDT
Downloaded kernel-2.6.25.10-83.fc9.i686 from koji this morning, and all is well.
 Thanks for the super-duper-fast fix.  

Note You need to log in before you can comment on or make changes to this bug.