Bug 454038 - Additional columns available in query resultsgroups doesn't wrap
Additional columns available in query resultsgroups doesn't wrap
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks: RHBZ30UpgradeTracker
  Show dependency treegraph
 
Reported: 2008-07-03 21:54 EDT by Noura El hawary
Modified: 2013-06-24 00:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 12:19:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 wrapping addtional columns in buglist.cgi (917 bytes, patch)
2008-07-03 22:00 EDT, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Noura El hawary 2008-07-03 21:54:27 EDT
Additional columns added to the query resultgroups, "Depends On, Blocked By,
flags, Issue Tracker" do not wrap their text when they have large contents.
Comment 1 Noura El hawary 2008-07-03 22:00:52 EDT
Created attachment 310972 [details]
v1 wrapping addtional columns in buglist.cgi

as an example of this problem please see,

https://bz-web2-test.devel.redhat.com/buglist.cgi?bug_id=440169&columnlist=bug_severity%2Cpriority%2Crep_platform%2Cassigned_to%2Cbug_status%2Cresolution%2Cop_sys%2Cdependson%2Cblockedby%2Cshort_desc&field-1-0-0=bug_id&query_format=advanced&remaction=&type-1-0-0=anyexact&value-1-0-0=440169&query_based_on=


attached is a patch to fix it and add the wrap option to those columns I am not
sure if this is the right place to the the option or it should be added to an
extension, i can not find the hook "list_table_abbrev" that is mentioned in
template/en/default/list/table.html.tmpl ,, also the patch in the bug 406151
doesn't include this hook. 

Please review when you can. 

Thanks,
Noura
Comment 2 David Lawrence 2008-07-04 00:51:08 EDT
Comment on attachment 310972 [details]
v1 wrapping addtional columns in buglist.cgi

If we did it with an extension it would be 

extensions/<extension_name>/template/en/list/table-list_table_abbrev.html.tmpl

but since we have the columns in the Bugzilla code in several places already 
such as Bugzilla/Search.pm, colchange.cgi, field-descs.none.tmpl, etc. I think
we can leave it in the templates as well for now. So your patch looks fine to
me.

Just put REDHAT EXTENSION around the section similar to how we have it in
template/en/default/global/field-descs.none.tmpl. And then check it in.

Dave
Comment 3 Noura El hawary 2008-07-04 01:42:38 EDT
Thanks for the review Dave ,, all committed to cvs now.

Noura

Note You need to log in before you can comment on or make changes to this bug.