Bug 454154 - iwl3945 is unable to connect to wireless network
iwl3945 is unable to connect to wireless network
Status: CLOSED DUPLICATE of bug 453390
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-05 11:32 EDT by Leonid Kanter
Modified: 2008-07-10 15:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 15:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
connection attempt using iwl3945 (4.24 KB, text/plain)
2008-07-05 11:32 EDT, Leonid Kanter
no flags Details
Successful connection using ndiswrapper card (5.32 KB, text/plain)
2008-07-05 11:34 EDT, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2008-07-05 11:32:44 EDT
Description of problem:

iwl3945 is unable to connect to wireless network. ndiswrapper works fine with
same NetworkManager setup. iwl3945 in FC7 works fine on the same hardware.

Version-Release number of selected component (if applicable):

kernel-2.6.25.9-76.fc9.i686

How reproducible:

always

Steps to Reproduce:
1. Load F9 on Dell D620 equipped with IPW3945 wireless card
2. Try to connect to WPA Personal/TKIP/PSK AP 
  
Actual results:

Unable to connect to AP

Expected results:

Must connect to AP

Additional info:

All networks are visible, but unable to authenticate on AP. I tried to play with
options hwcrypto and disable_hw_scan options - no success. But ndiswrapper works
fine with the same NetworkManager setup.
Comment 1 Leonid Kanter 2008-07-05 11:32:44 EDT
Created attachment 311068 [details]
connection attempt using iwl3945
Comment 2 Leonid Kanter 2008-07-05 11:34:02 EDT
Created attachment 311069 [details]
Successful connection using ndiswrapper card
Comment 3 Sebastian Pölsterl 2008-07-05 13:09:36 EDT
I can confirm this problem. It works with kernel 2.6.25.6-55.fc9.i686 for me,
but not with 2.6.25.9-76.fc9.i686
Comment 4 Leonid Kanter 2008-07-05 18:21:11 EDT
I don't have 2.6.25.6-55.fc9.i686, only initial 2.6.25-14.fc9 because system was
just installed. Tried to boot 2.6.25-14.fc9 - works fine.
Comment 5 Richard Körber 2008-07-06 04:47:23 EDT
I can confirm this issue on the kernel 2.6.25.9-76.fc9.x86_64. Working fine
again when booting kernel 2.6.25.6-55.fc9.x86_64.
Comment 6 nathan r. hruby 2008-07-06 12:24:08 EDT
DITTO: 

Dell D620 with iwl3954 upgraded to 2.6.25.9-76.fc9.i686 yesterday and wireless
stopped working using NM (and WPA), error appears to be at the point of the
"wlan0: link timed out." error message as shown in comment #1.  

AP appears to be fine as the macs and wii continue to work.

Note that Dell has an a10 firmware out for the d620:
http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R186796&SystemID=LATITUDE
D620&servicetag=&os=BIOSA&osl=en&deviceid=10109&devlib=0&typecnt=0&vercnt=9&catid=-1&impid=-1&formatcnt=1&libid=1&fileid=255482

This appears to have wireless compat fixes which may help, sadly, the
firmware-tools as shipped in F9 is too old to install this firmware using the
Dell tools, which are requiring firmware-tools >= 2.0.0.  Bug to bump
firmware-tools is #454204
Comment 7 nathan r. hruby 2008-07-06 12:47:59 EDT
Tried the BIOS update from above (a09 -> a10) which does not appear to resolve
the problem.  Bummer.
Comment 8 Hans Ulrich Niedermann 2008-07-07 04:46:54 EDT
I can confirm this is a regression from kernel-PAE-2.6.25.6-55.fc9.i686 (works)
to kernel-PAE-2.6.25.9-76.fc9.i686 (breaks).

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
        Subsystem: Intel Corporation ThinkPad R60e/X60s
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at edf00000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
        Capabilities: [e0] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [140] Device Serial Number 78-b0-9d-ff-ff-02-13-00
        Kernel driver in use: iwl3945
        Kernel modules: iwl3945



Comment 9 Marcus Alves Grando 2008-07-08 11:28:52 EDT
More one with same problem. Same thing of comment 3.
Comment 10 Richard Körber 2008-07-08 13:19:14 EDT
This bug does not seem to be just iwl3945 related! I could also reproduce it on
a machine with a Linksys WMP54G (RaLink RT2561/RT61) using the rt61pci driver.
Again, no connection possible with 2.6.25.9-76.fc9.x86_64, but working with
2.6.25.6-55.fc9.x86_64.
Comment 11 Danny Baumann 2008-07-10 13:30:04 EDT
Confirmed on iwl3945 as well, same "link timed out" problem.
.55 works, .76 does not work.
Comment 12 Hans Ulrich Niedermann 2008-07-10 14:30:27 EDT
Is there any ETA on a fix?
Comment 13 John W. Linville 2008-07-10 15:02:15 EDT

*** This bug has been marked as a duplicate of 453390 ***

Note You need to log in before you can comment on or make changes to this bug.