Bug 454218 - ehci_usb: External USB 2.0-hdd keeps being reset; works when using USB 1.1
ehci_usb: External USB 2.0-hdd keeps being reset; works when using USB 1.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-06 17:13 EDT by Stefan Neufeind
Modified: 2008-07-30 19:30 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.25.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 19:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-07-06 17:13:10 EDT
I experience the problem e.g. described here:
http://fedoraforum.org/forum/showthread.php?t=103776

Attaching the device, browsing and starting to copy files to/from it works fine.
But during copy after a short while the copying gets stuck and all of a sudden
syslog shows

  kernel: usb 2-1: reset high speed USB device using ehci_hcd and address 3

then the stall is gone for another minute or so. Unloading ehci_usb manually
(actually dropping down to USB 1.1) works, but sure is slow.
Comment 1 Chuck Ebbert 2008-07-09 15:21:18 EDT
Can you try a 2.6.25.10 based kernel when it becomes available?
Comment 2 Stefan Neufeind 2008-07-30 19:29:14 EDT
Had the chance to lately check the problematic device again with kernel
2.6.25.11-97.fc9.x86_64. Seems to work fine now.

Note You need to log in before you can comment on or make changes to this bug.