Bug 454227 - crash with gtkhtml2-viewer plugin
crash with gtkhtml2-viewer plugin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: claws-mail-plugins (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-07-06 20:18 EDT by Jens Petersen
Modified: 2009-03-19 11:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 11:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unsolicited-crash.eml.gz (7.76 KB, application/x-gzip)
2008-07-06 20:19 EDT, Jens Petersen
no flags Details
Fix this crash (2.41 KB, patch)
2008-08-24 05:23 EDT, Colin Leroy
no flags Details | Diff

  None (edit)
Description Jens Petersen 2008-07-06 20:18:02 EDT
Description of problem:
Claws-mail crashed for me when trying to render the attached unsolicited mail.

Version-Release number of selected component (if applicable):
claws-mail-plugins-gtkhtml2-viewer-3.5.0

Steps to Reproduce:
1. install claws-mail-plugins-gtkhtml2-viewer
2. view attached mail
  
Actual results:
crashes

Expected results:
no crash

Additional info:
[petersen@dhcp-0-235]~/fedora/comps% gdb claws-mail
GNU gdb Fedora (6.8-10.fc9)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) run
Starting program: /usr/bin/claws-mail
[Thread debugging using libthread_db enabled]
[New Thread 0x7fdca6aca7b0 (LWP 29012)]
Detaching after fork from child process 29016.
Detaching after fork from child process 29018.
Detaching after fork from child process 29020.
[New Thread 0x41938950 (LWP 29022)]

** (claws-mail:29012): WARNING **: [10:03:57] IMAP error: LOGIN error

Unhandled property: 12 border-collapse
Unhandled property: 4 background-position
Unhandled property: 1 background-attachment

Program received signal SIGSEGV, Segmentation fault.
0x0000003214e595b0 in g_str_hash () from /lib64/libglib-2.0.so.0
Missing separate debuginfos, use: debuginfo-install aspell.x86_64 atk.x86_64
bluez-libs.x86_64 bug-buddy.x86_64 cairo.x86_64 claws-mail-plugins.x86_64
compface.x86_64 curl.x86_64 cyrus-sasl.x86_64 db4.x86_64 dbus-glib.x86_64
dbus.x86_64 e2fsprogs.x86_64 elfutils.x86_64 expat.x86_64 fontconfig.x86_64
freetype.x86_64 gail.x86_64 gcc.x86_64 glib2.x86_64 glibc.x86_64 gpgme.x86_64
gtk-nodoka-engine.x86_64 gtk2.x86_64 keyutils.x86_64 krb5.x86_64 libICE.x86_64
libSM.x86_64 libX11.x86_64 libXau.x86_64 libXcomposite.x86_64 libXcursor.x86_64
libXdmcp.x86_64 libXext.x86_64 libXfixes.x86_64 libXi.x86_64 libXinerama.x86_64
libXrandr.x86_64 libXrender.x86_64 libcap.x86_64 libetpan.x86_64
libgpg-error.x86_64 libidn.x86_64 libpng.x86_64 libselinux.x86_64 libusb.x86_64
libxcb.x86_64 libxml2.x86_64 nspr.x86_64 nss.x86_64 openldap.x86_64
openssl.x86_64 pango.x86_64 pilot-link.x86_64 pixman.x86_64 scim-bridge.x86_64
startup-notification.x86_64 zlib.x86_64
(gdb) bt
#0  0x0000003214e595b0 in g_str_hash () from /lib64/libglib-2.0.so.0
#1  0x0000003214e2a06d in g_hash_table_lookup () from /lib64/libglib-2.0.so.0
#2  0x00007fdc9ec1e84c in html_image_factory_get_image ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#3  0x00007fdc9ec0c308 in ?? ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#4  0x00007fdc9ec0c6f4 in css_matcher_apply_rule ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#5  0x00007fdc9ec0fe88 in css_matcher_get_style ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#6  0x00007fdc9ec15c87 in ?? ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#7  0x00007fdc9ec16661 in ?? ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#8  0x000000321520b6dd in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#9  0x000000321521f6c1 in ?? () from /lib64/libgobject-2.0.so.0
#10 0x0000003215220b9c in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#11 0x00000032152210e3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#12 0x0000003ff2073b37 in ?? () from /usr/lib64/libxml2.so.2
#13 0x0000003ff20755a7 in htmlParseChunk () from /usr/lib64/libxml2.so.2
#14 0x00007fdc9ec38a99 in html_stream_write ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
---Type <return> to continue, or q <return> to quit---
#15 0x00007fdc9ec0a5a3 in ?? ()
   from /usr/lib64/claws-mail/plugins/gtkhtml2_viewer.so
#16 0x0000003214e37c9b in ?? () from /lib64/libglib-2.0.so.0
#17 0x0000003214e374db in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#18 0x0000003214e3acbd in ?? () from /lib64/libglib-2.0.so.0
#19 0x0000003214e3b1ed in g_main_loop_run () from /lib64/libglib-2.0.so.0
#20 0x0000003215f83a98 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#21 0x00000000004d2d99 in main (argc=1, argv=0x7fffaeb05888) at main.c:1629

Is it safer to use the dillo plugin?
Comment 1 Jens Petersen 2008-07-06 20:19:22 EDT
Created attachment 311111 [details]
unsolicited-crash.eml.gz
Comment 2 Colin Leroy 2008-08-24 05:23:50 EDT
Created attachment 314880 [details]
Fix this crash

This is fixed upstream by this patch.
Comment 3 Bug Zapper 2008-11-25 21:31:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Michael Schwendt 2009-03-19 11:53:30 EDT
Fixed last year since claws-mail-plugins-3.6.0-1.fc10 and 
claws-mail-plugins-3.6.1-1.fc9

Note You need to log in before you can comment on or make changes to this bug.