Bug 454278 - crash on randr
crash on randr
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 09:48 EDT by Jeremy Katz
Modified: 2009-10-22 08:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 17:09:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (128.68 KB, text/plain)
2008-07-07 09:48 EDT, Jeremy Katz
no flags Details

  None (edit)
Description Jeremy Katz 2008-07-07 09:48:15 EDT
When getting to the office and plugging my laptop into the external display, I
do something along the lines of
  xrandr --output VGA --mode 1680x1050 --output LVDS --off
(either via command line or the gnome tool).  Recently, this started crashing
the X server.  Looking in the X.log shows a nice segfault backtrace

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x79) [0x80bcaa9]
1: [0x132400]
2: /usr/bin/Xorg(xf86ModesEqual+0xc) [0x80ed67c]
3: /usr/bin/Xorg(xf86SetScrnInfoModes+0x1b3) [0x80e70f3]
4: /usr/bin/Xorg [0x80eeed8]
5: /usr/bin/Xorg(RRGetInfo+0xb1) [0x816dd81]
6: /usr/bin/Xorg(ProcRRGetScreenResources+0x85) [0x8171c75]
7: /usr/bin/Xorg [0x816ab05]
8: /usr/bin/Xorg(Dispatch+0x34f) [0x8085c8f]
9: /usr/bin/Xorg(main+0x47d) [0x806b60d]
10: /lib/libc.so.6(__libc_start_main+0xe5) [0x3c35d5]
11: /usr/bin/Xorg(FontFileCompleteXLFD+0x229) [0x806a9f1]

Only "odd" thing in my xorg.conf is a Virtual of 2048x2048 and wacom setup
Comment 1 Jeremy Katz 2008-07-07 09:48:15 EDT
Created attachment 311149 [details]
X log
Comment 2 Jeremy Katz 2008-07-07 15:39:51 EDT
Oh, and

xorg-x11-server-Xorg-1.4.99.905-2.20080701.fc10.i386
xorg-x11-drv-i810-2.2.1-24.fc9.i386
Comment 3 Peter Hutterer 2008-10-22 21:59:51 EDT
Jeremy, is this still an issue? Looks like it was fixed with the patch below.

commit 1771edcb44b564f83f509748b4e4cd5b7586e2a8
Author: Dave Airlie <airlied@redhat.com>
Date:   Thu Jul 3 18:57:09 2008 +1000

    modes: check the crtc is valid before using its desired modes.
    
    this fixes a crash I was getting on radeon rotate when gnome is running.
    I'm sure g-s-d was doing something bad, but really not crashing ftw.
Comment 4 Jeremy Katz 2008-11-03 17:09:38 EST
Looks okay now, yeah

Note You need to log in before you can comment on or make changes to this bug.