Bug 45428 - nethack save option does not work
Summary: nethack save option does not work
Status: CLOSED DUPLICATE of bug 20454
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: nethack   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-21 19:44 UTC by Michael Meissner
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-21 19:44:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Meissner 2001-06-21 19:44:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3 i686)

Description of problem:
If you attempt to save a nethack game and the recover the saved game, the
game will print version mismatch and create a new game.

How reproducible:
Always

Steps to Reproduce:
1.start nethack
2.Save a game with the capital S command
3.start nethack again
4.nethack will complain of version mismatch of the old save file, and start
a new game.
	

Actual Results:  Save file ignored, new game started.

Expected Results:  Old game should be restored.

Additional info:

I edited the patch file, and changed the use of bzip2 to use gzip, and
removed the special options passed to the compresser, rebuilt nethack and
it worked correctly.

Comment 1 Bernhard Rosenkraenzer 2001-06-25 09:23:43 UTC

*** This bug has been marked as a duplicate of 20454 ***


Note You need to log in before you can comment on or make changes to this bug.