Bug 454337 - RHEL5 cmirror tracker: creation is broken in latest build
RHEL5 cmirror tracker: creation is broken in latest build
Status: CLOSED DUPLICATE of bug 455453
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cmirror (Show other bugs)
5.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 15:15 EDT by Corey Marthaler
Modified: 2010-01-11 21:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 12:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-07-07 15:15:26 EDT
Description of problem:
Simple cmirror creation is broken in the last builds.

[root@hayes-02 ~]# lvcreate -m 1 -n test -L 10M corey
  Rounding up size to full physical extent 12.00 MB
  Error locking on node hayes-03: Command timed out
  Error locking on node hayes-02: Command timed out
  Error locking on node hayes-01: Command timed out
  Aborting. Failed to activate new LV to wipe the start of it.
  Error locking on node hayes-03: Command timed out
  Error locking on node hayes-02: Command timed out
  Error locking on node hayes-01: Command timed out
[HANG]

From console:
Jul  7 14:03:07 hayes-01 kernel: device-mapper: dm-log-clustered: [nQeF5EsU] Requeg
Jul  7 14:03:07 hayes-01 clogd[3248]: Invalid log request received, ignoring.
device-mapper: dm-log-clustered: [nQeF5EsU] Request timed out: [DM_CLOG_CTR/428] -g
Jul  7 14:03:22 hayes-01 kernel: device-mapper: dm-log-clustered: [nQeF5EsU] Requeg
Jul  7 14:03:22 hayes-01 clogd[3248]: Invalid log request received, ignoring.
device-mapper: dm-log-clustered: [nQeF5EsU] Request timed out: [DM_CLOG_CTR/429] -g
Jul  7 14:03:37 hayes-01 kernel: device-mapper: dm-log-clustered: [nQeF5EsU] Requeg
Jul  7 14:03:37 hayes-01 clogd[3248]: Invalid log request received, ignoring.


Version-Release number of selected component (if applicable):
[root@hayes-03 bin]# ./lvm_rpms
2.6.18-92.1.5.el5

lvm2-2.02.32-4.el5    BUILT: Fri Apr  4 06:15:19 CDT 2008
lvm2-cluster-2.02.32-4.el5    BUILT: Wed Apr  2 03:56:50 CDT 2008
device-mapper       BUILT: Thu 17 Jan 2008 04:46:05 PM CST
cmirror-1.1.19-1.el5    BUILT: Wed Jul  2 16:33:53 CDT 2008
kmod-cmirror-0.1.10-1.el5    BUILT: Tue May 20 14:55:48 CDT 2008


How reproducible:
Everytime
Comment 1 Jonathan Earl Brassow 2008-07-08 17:36:31 EDT
bug was in build (spec file).  Should be fixed now.
Comment 2 Corey Marthaler 2008-07-08 17:58:18 EDT
Fix verified in cmirror-1.1.19-2.el5.
Comment 3 Corey Marthaler 2008-07-15 12:06:02 EDT
This actually turned out to be a small size creation issue, and not a build issue. 

Closing this as a dup of 455453.

*** This bug has been marked as a duplicate of 455453 ***

Note You need to log in before you can comment on or make changes to this bug.