Bug 454349 - appears that dmevent needs to be restarted
appears that dmevent needs to be restarted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 17:09 EDT by Corey Marthaler
Modified: 2010-01-11 22:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:46:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-07-07 17:09:58 EDT
Description of problem:
Otherwise you'll end up with the following messages over and over while doing
lvm operations:

event registration failed: 30718:9 libdevmapper-event-lvm2mirror.so dlopen
failed: /lib64/libdevmapper-event-lvm2mirror.so: undefined symbol: lvm2_run


Version-Release number of selected component (if applicable):
2.6.18-92.el5

lvm2-2.02.39-1.el5    BUILT: Thu Jul  3 08:41:39 CDT 2008
lvm2-cluster-2.02.39-1.el5    BUILT: Thu Jul  3 09:31:57 CDT 2008
device-mapper-1.02.27-1.el5    BUILT: Thu Jul  3 03:22:29 CDT 2008
Comment 1 Petr Rockai 2008-07-08 05:06:28 EDT
There is a slight problem with dmeventd restart, since we have to re-register 
all the monitored volumes and I don't think there currently is a way to do so 
reliably. But we likely want to fix that for 5.3.
Comment 2 RHEL Product and Program Management 2008-07-08 05:34:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Milan Broz 2008-07-08 05:45:38 EDT
Even if there is only warning about need of re-activate volumes to start
monitoring for them is better than dmeventd in non-functional state because of
incompatible plugins.
Comment 5 Petr Rockai 2008-07-08 15:33:53 EDT
Current proposed fix (it is a little ugly, beut should work):

1) Make the "to be monitored" a persistent logical volume property.
2) This can be non-intrusively (in a backward-compatible manner) done by adding 
an inverted flag to metadata (say NOMONITORING): if the flag is cleared, it 
means that the device will be (if possible) monitored (which is the default) 
and when it is set, the device is excluded from monitoring.
3) Add a vgchange (sub-)command to register all applicable LVs for 
monitoring -- this can then be used for starting dmeventd after upgrades.

We do 2) to avoid having to flag existing devices upon upgrade, as Milan 
pointed out, a possibly dangerous operation.
Comment 6 Corey Marthaler 2008-07-08 15:47:35 EDT
I restarted dmeventd and still ended up seeing these errors, could this be a
different issue?
Comment 7 Milan Broz 2008-07-09 08:31:59 EDT
ok, that issue was caused by broken build, it is fixed in lvm2-2.02.39-2.el5

I'll clone separate bug for dmeventd restart, just to not forget ideas :)
Comment 8 Corey Marthaler 2008-07-09 13:05:37 EDT
Fix verified in lvm2-2.02.39-2.el5.
Comment 10 errata-xmlrpc 2009-01-20 16:46:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0179.html

Note You need to log in before you can comment on or make changes to this bug.