Bug 454358 - selinux denials to pppd when using Network Manager
selinux denials to pppd when using Network Manager
Status: CLOSED DUPLICATE of bug 249152
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 18:48 EDT by Brian G. Anderson
Modified: 2008-09-02 07:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 07:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
AVC messages about pppd denials (2.16 KB, application/octet-stream)
2008-07-07 18:51 EDT, Brian G. Anderson
no flags Details

  None (edit)
Description Brian G. Anderson 2008-07-07 18:48:29 EDT
Description of problem:
I have network manager (NM) setup to use my bluetooth phone as a mobile
broadband modem.  When I initiate a connection I get selinux failures about pppd
not be allowed to access "/var/run/pppd2.tdb".

I can sucessfully connect if I disable selinux or a I make a custom policy
(which is what I did).  I'll attach the avc messages I got in the log and that I
used to make my local policy


Version-Release number of selected component (if applicable):
ppp-2.4.4-7.fc9.x86_64
selinux-policy-targeted-3.3.1-74.fc9.noarch
selinux-policy-3.3.1-74.fc9.noarch



How reproducible:
Every time

Steps to Reproduce:
1. Setup a broadband connection needing ppp.
2. Try and connect using nm-applet
3.
  
Actual results:
Connection fails and setroubleshooter emits failure warnings

Expected results:
Successful connection

Additional info:
Comment 1 Brian G. Anderson 2008-07-07 18:51:33 EDT
Created attachment 311209 [details]
AVC messages about pppd denials
Comment 2 Jiri Skala 2008-08-20 09:50:57 EDT
I tested following commands to allow this and it works at me:

# audit2allow -M mypol -l -i /var/log/audit/audit.log
# semodule -i mypol.pp

This issue should fix new release of selinux-policy.
Comment 3 Jiri Skala 2008-09-02 07:52:25 EDT
I tested it with selinux-policy-3.3.1-87.fc9.noarch and it works fine.

*** This bug has been marked as a duplicate of bug 249152 ***

Note You need to log in before you can comment on or make changes to this bug.