Bug 45445 - /sbin/cardctl scheme <new scheme> doesn't reconfigure wireless device
Summary: /sbin/cardctl scheme <new scheme> doesn't reconfigure wireless device
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-21 20:59 UTC by Jason Gilbert
Modified: 2015-01-04 22:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 22:39:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Gilbert 2001-06-21 20:59:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5-0.4 i686)

Description of problem:
Executing cardctl scheme <new scheme> to change to a new pcmcia scheme
configuration does not reconfigure a wireless device to new settings.  I
have not tried it changing the scheme with any non-wireless devices to
verify if they work.

How reproducible:
Always

Steps to Reproduce:
1.  /sbin/cardctl scheme work ('work' scheme configured in
/etc/pcmcia/wireless.opts)
2.  restart pcmcia or eject/insert card to get it to reconfigure.
3.  /sbin/cardctl scheme home (different scheme configured similarly to
'work')
4. still has work iwconfig and IP address settings.
	

Actual Results:  Still had same settings

Expected Results:  iwconfig eth0 should report the new settings for the
different scheme and an IP address should not be available since the new
scheme settings are no longer valid at the current location.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.