Bug 454458 - Translation for KPovModeler shouldn't be there
Translation for KPovModeler shouldn't be there
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-i18n (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-08 12:36 EDT by Andrea Santilli
Modified: 2008-09-10 03:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 03:19:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Santilli 2008-07-08 12:36:19 EDT
Description of problem:
I was building a RPM package for KPovModeler since Fedora does not include it.
Everything went find except the installation. Here is what I got:

$ sudo rpm -ivh kpovmodeler-1.1.2-1.fc9.i386.rpm
Preparazione in corso...    ########################################### [100%]
        il file /usr/share/locale/it/LC_MESSAGES/kpovmodeler.mo
dell'installazione di kpovmodeler-1.1.2-1.fc9.i386 entra in conflitto con il
file del pacchetto kde-i18n-Italian-3.5.9-5.fc9.noarch

Meaning that file /usr/share/locale/it/LC_MESSAGES/kpovmodeler.mo from
kpovmodeler-1.1.2-1.fc9.i386 (the package I made) conflicts with the same file
from package kde-i18n-Italian-3.5.9-5.fc9.noarch.

I suppose that translation is included for all other languages too.

Version-Release number of selected component (if applicable):
3.5.9-5.fc9

Expected results:
Exclude the translation files for KPovModeler from KDE 3.x
Comment 1 Kevin Kofler 2008-07-19 21:06:20 EDT
I guess we should probably be whitelisting rather than blacklisting in 
kde-i18n. But for now, getting rid of the kpovmodeler translations is easy.
Comment 2 Kevin Kofler 2008-07-19 21:16:57 EDT
Fixed for Rawhide now, F9 will get the fix in the big KDE 4.1 update (as the 
new kde-i18n also fixes conflicts with KDE 4.1, so it has to pushed with KDE 
4.1 anyway).
Comment 3 Fedora Update System 2008-07-30 16:07:07 EDT
kdeutils-4.1.0-1.fc9.1, kdeedu-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, PyQt4-4.4.2-2.fc9, automoc-1.0-0.8.rc1.fc9, phonon-4.2.0-2.fc9, kdegraphics-4.1.0-3.fc9, kdelibs-4.1.0-2.fc9, kdebase-runtime-4.1.0-1.fc9, akonadi-1.0.0-1.fc9, kdepimlibs-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, kde-filesystem-4-17.fc9, kde-l10n-4.1.0-2.fc9, kdebase-workspace-4.1.0-3.fc9, kdemultimedia-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdeaccessibility-4.1.0-1.fc9, kdegames-4.1.0-1.fc9, kdeplasma-addons-4.1.0-1.fc9, qscintilla-2.2-3.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.0-16.fc9, kdebindings-4.1.0-5.fc9, kdeartwork-4.1.0-1.fc9, kde-i18n-3.5.9-8.fc9, kdeadmin-4.1.0-2.fc9, kdebase-4.1.0-1.fc9.1, soprano-2.1-1.fc9, sip-4.7.6-1.fc9, kdenetwork-4.1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdeedu qgtkstyle PyQt4 automoc phonon kdegraphics kdelibs kdebase-runtime akonadi kdepimlibs kdesdk kde-filesystem kde-l10n kdebase-workspace kdemultimedia kdetoys kdeaccessibility kdegames kdeplasma-addons qscintilla compiz qt kdebindings kdeartwork kde-i18n kdeadmin kdebase soprano sip kdenetwork'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 4 Fedora Update System 2008-08-07 19:48:37 EDT
kdebase-runtime-4.1.0-1.fc9, kdeaccessibility-4.1.0-1.fc9, kdegames-4.1.0-1.fc9, kdeplasma-addons-4.1.0-1.fc9, kdebase-workspace-4.1.0-8.fc9, kdebase-4.1.0-1.fc9.1, qgtkstyle-0.0-0.2.20080719svn693.fc9, qt-4.4.0-17.fc9, kdeutils-4.1.0-1.fc9.1, qscintilla-2.2-3.fc9, kdegraphics-4.1.0-3.fc9, kde-i18n-3.5.9-8.fc9, kdeartwork-4.1.0-1.fc9, kdeedu-4.1.0-1.fc9, compiz-0.7.6-3.fc9.1, PyQt4-4.4.2-2.fc9, automoc-1.0-0.8.rc1.fc9, phonon-4.2.0-2.fc9, akonadi-1.0.0-2.fc9, kdenetwork-4.1.0-2.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, sip-4.7.6-1.fc9, kdepimlibs-4.1.0-2.fc9, kdelibs-4.1.0-4.fc9, kdebindings-4.1.0-5.fc9, kdesdk-4.1.0-1.fc9, kde-filesystem-4-17.fc9, soprano-2.1-1.fc9, kde-l10n-4.1.0-2.fc9, kdemultimedia-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-runtime kdeaccessibility kdegames kdeplasma-addons kdebase-workspace kdebase qgtkstyle qt kdeutils qscintilla kdegraphics kde-i18n kdeartwork kdeedu compiz PyQt4 automoc phonon akonadi kdenetwork quarticurve-kwin-theme sip kdepimlibs kdelibs kdebindings kdesdk kde-filesystem soprano kde-l10n kdemultimedia kdetoys kdeadmin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 5 Fedora Update System 2008-08-12 14:18:37 EDT
kdelibs-4.1.0-5.fc9, kdeedu-4.1.0-1.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, kdeartwork-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, PyQt4-4.4.2-2.fc9, kde-i18n-3.5.9-8.fc9, kdebase-4.1.0-1.fc9.1, sip-4.7.6-1.fc9, phonon-4.2.0-2.fc9, kdebase-workspace-4.1.0-8.fc9, automoc-1.0-0.8.rc1.fc9, kdegames-4.1.0-2.fc9, akonadi-1.0.0-2.fc9, soprano-2.1-1.fc9, konq-plugins-4.1.0-2.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.1-2.fc9, qscintilla-2.2-3.fc9, kdepimlibs-4.1.0-2.fc9, kdegraphics-4.1.0-3.fc9, kdebindings-4.1.0-5.fc9, kdenetwork-4.1.0-2.fc9, kde-l10n-4.1.0-2.fc9, kdeplasma-addons-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, kdeutils-4.1.0-1.fc9.1, kdemultimedia-4.1.0-1.fc9, kdebase-runtime-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9, kde-filesystem-4-17.fc9, kdeaccessibility-4.1.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeedu quarticurve-kwin-theme kdeartwork kdetoys kdesdk PyQt4 kde-i18n kdebase sip phonon kdebase-workspace automoc kdegames akonadi soprano konq-plugins compiz qt qscintilla kdepimlibs kdegraphics kdebindings kdenetwork kde-l10n kdeplasma-addons qgtkstyle kdeutils kdemultimedia kdebase-runtime kdeadmin kde-filesystem kdeaccessibility'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 6 Fedora Update System 2008-09-10 03:18:33 EDT
kdeedu-4.1.0-1.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, kdeartwork-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, PyQt4-4.4.2-2.fc9, kde-i18n-3.5.9-8.fc9, kdebase-4.1.0-1.fc9.1, sip-4.7.6-1.fc9, kdebase-workspace-4.1.0-8.fc9, automoc-1.0-0.8.rc1.fc9, kdegames-4.1.0-2.fc9, akonadi-1.0.0-2.fc9, soprano-2.1-1.fc9, konq-plugins-4.1.0-2.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.1-2.fc9, qscintilla-2.2-3.fc9, kdepimlibs-4.1.0-2.fc9, kdebindings-4.1.0-5.fc9, kdenetwork-4.1.0-2.fc9, kde-l10n-4.1.0-2.fc9, kdeplasma-addons-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, kdeutils-4.1.0-1.fc9.1, kdemultimedia-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9, kde-filesystem-4-17.fc9, kdeaccessibility-4.1.0-1.fc9, kdebase-runtime-4.1.0-3.fc9, phonon-4.2.0-4.fc9, kdegraphics-4.1.0-5.fc9, kdelibs-4.1.0-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.