Bug 454472 - update reversing itself
update reversing itself
Status: CLOSED DUPLICATE of bug 471579
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-08 13:39 EDT by Ray Todd Stevens
Modified: 2008-12-05 13:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 22:53:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-07-08 13:39:56 EDT
I don't have a lot of information on this but I thought that a heads up was in
order.

I did a preupgrade upgrade of a fc8 server to fc9.   It appeared to take, but
now it is slowing undoing itself.   Apparently during the process the
fecora-release rpm for both fc8 and fc9 were left on the machine.   I assume
that the fc8 one should have been removed by the anaconda installer.  So it is
only looking at the fc8 repositories.   This has causing a lot of problems as
every time I did a yum update it kept pulling in fc8 rpms and installing them. 
Some times it was removing the fc9 one some times it was not.   Not good.

I have only seen this once.   I am not sure what caused it.   I could test or
look at anything you want me to, but I am not sure what would be convient.

Mainly this is a heads up in case someone is experiencing this upgrade reversing
problem.
Comment 1 Chris Lumens 2008-11-17 11:55:00 EST
When you say both the F8 and F9 fedora-release RPMs were left installed, did you verify this with rpm -q, or did you assume based on the presence of /etc/yum.repos.d/ files?  It seems to me like you might have both fedora.repo files installed (or perhaps the F9 one got written as fedora.repo.rpmnew) and left your F8 configuration enabled.  See bug 471579 for what seems like a related problem.
Comment 2 Ray Todd Stevens 2008-11-17 12:06:40 EST
Both the redora-release rpms were listed as installed with a rpm -q

I fixed the problem by doing a removal of BOTH and then installing the fc9 one.   Then I had to search for the fc8 rpms and see if they had replaced a fc9 and if they were installed with an fc9 that remained installed.   When both were installed generally I deinstalled both and then reinstalled the current fc9.
Comment 3 Ray Todd Stevens 2008-11-17 12:08:30 EST
The listed bug does sound similar.
Comment 4 Ray Todd Stevens 2008-12-02 17:01:35 EST
I have not had this happen any more, and other than the real hassel of reupgrading everything manually and with a good deal of research for each thing upgraded this is now fixed.
Comment 5 Chris Lumens 2008-12-04 22:53:21 EST
Closing as a dupe on the basis of comment #3, though I don't know how we're going to be able to replicate the original conditions in this bug report.

*** This bug has been marked as a duplicate of bug 471579 ***
Comment 6 Ray Todd Stevens 2008-12-05 13:59:30 EST
I think closing this is a good idea.

I mainly was reporting it as a way to have anyone else also having problems have a place to start in tracking and repairing those problems.   Unless we got a bunch of people saying "yes that is also me" I was expecting it to be closed without a lot of work on it.

Note You need to log in before you can comment on or make changes to this bug.